


Sobre este eBook

Este eBook é um guia completo e detalhado que apresenta o Apache NetBeans 16 como

uma solução excelente para quem busca um software gratuito e com poderosos recursos

para o desenvolvimento de aplicações web PHP 8.1. 

Este eBook tem por objetivo ensinar a configurar e utilizar (passo a passo) o Apache

NetBeans 16, proporcionando ao desenvolvedor um ambiente completo, mais produtivo e

melhor.

Dúvidas, Sugestões, Elogios, Erros

 Email: aprendanetbeans@gmail.com 

 Site: aprendanetbeans.github.io
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Olá, muito obrigado por adquirir este eBook, aqui você encontrará o maior número de

informações possíveis sobre o Apache NetBeans 16 de forma organizada para que possa

tirar o máximo proveito do que este software tem para oferecer no desenvolvimento e

estudo de aplicações web PHP 8.1.

Espero que este eBook lhe agregue conhecimento e ajude a tornar  seu ambiente de

desenvolvimento completo, mais produtivo e melhor! 
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Capítulo 1 – Introdução 

Muitos desenvolvedores PHP, principalmente no início, já ficaram na dúvida sobre qual

software utilizar para escreverem os seus códigos e auxiliá-los desenvolvimento de suas

aplicações, pois há inúmeras soluções no mercado desde editores (Visual Studio Code,

Sublime Text,  e etc.)  até as IDEs (PHPStorm, Apache NetBeans,  Eclipse e etc).  E a

procura por um software para auxiliar no desenvolvimento de aplicações web PHP tende

a ser estressante por tomar uma boa parte do nosso tempo tentando escolher “o melhor”

e  também  por  não  encontrar  material  suficiente  para  aprendermos  por  completo  a

configurar e utilizar corretamente o software escolhido.

Sendo assim, ao longo deste eBook você terá a oportunidade conhecer e aprender a

configurar  e  utilizar  corretamente  um  software  excelente  no  desenvolvimento  de

aplicações  web  PHP  8.1  e  que  oferece  suporte  do  início  ao  fim  no  processo  de

desenvolvimento, chamado Apache NetBeans (versão 16).

1.1 Por que utilizar o Apache NetBeans 16 no desenvolvimento de 
aplicações PHP 8.1?

O Apache NetBeans 16 oferece suporte total ao desenvolvimento de aplicações web em

PHP  8.1  e  disponibiliza  em  seu  ambiente  muitas  ferramentas  para  esta  linguagem,

contudo vamos explorar as principais, como: editor de código com recursos específicos

(preenchimento  automático  de  códigos,  sugestões,  erros  de  sintaxe  e  entre  outros),

controle de versões da aplicação com Git / GitHub (requer conta GitHub), gerenciamento

de dependências (requer Composer), depuração da aplicação (requer Xdebug) e Cliente

FTP (requer uma hospedagem caso for implantar a aplicação em servidor remoto).

1.2 O que é o Apache NetBeans 16?

Apache NetBeans 16 é um software livre e open source que oferece um ambiente de

desenvolvimento  integrado,  também  conhecido  como  IDE  (Integrated  Development

Environment), com ferramentas poderosas para agilizar o desenvolvimento de aplicações

desktops, mobile e web.
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O Apache NetBeans 16 suporta o desenvolvimento de aplicações em várias linguagens,

tais como: Java, HTML5, PHP, Javascript e entre outras. E provê também suporte integral

no  desenvolvimento  de  um  projeto  (aplicação),  desde  sua  criação  até  implantação

(deploy).

Apache  NetBeans  16  é  mantido  pela  Apache  Software  Foundation  e  é  escrito  na

linguagem de programação Java, o que possibilita a instalação em sistemas operacionais

variados como Windows 10 / 11, macOS, Linux e entre outros. 

Observações:

 Neste eBook será usada a versão 16 do Apache NetBeans. Para saber mais sobre

essa versão, acesse o site oficial https://netbeans.apache.org/download/nb16/ (Em

inglês, acessado em 10 dez 2022).

 Para  saber  mais  sobre  a  Apache  Software  Foundation,  acesse  o  site  oficial

https://www.apache.org (Em inglês, acessado em 10 dez 2022).

1.3 O que é PHP 8.1?

O PHP (PHP: Hypertext Preprocessor), atualmente em sua versão 8.1, é uma linguagem

de script,  open  source,  server-side  (atua  do lado do servidor)  e  fácil  integração com

HTML5. Desde sua criação em 1994 por Rasmus Lerdorf e aprimoramento por parte de

Zeev Suraski e Andi Gutmans a partir de 1997, o PHP vem recebendo muitos adeptos,

mais recursos e melhorias magníficas de desempenho, o que o torna uma linguagem

muito poderosa, consolidada e bastante utilizada para o desenvolvimento web.

Atualmente estima-se que mais de 74% das aplicações web são escritas em PHP, dentre

elas, podemos destacar Facebook, Wordpress e Wikipédia. Caso queira saber detalhes

sobre a história do PHP e suas versões acesse: 

 https://www.php.net/history.php    (acessado em 10 dez 2022)

 https://en.wikipedia.org/wiki/PHP   (acessado em 10 dez 2022)

Observação:

 Neste eBook, será usada a versão 8.1.12 do PHP.

 Clique  aqui   e  conheça  o  curso  online  que  já  ajudou  milhares  de  pessoas  a

aprender a programar e a desenvolver projetos do Absoluto ZERO com PHP.
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Capítulo 2 – Softwares necessários

Para utilizar corretamente o Apache NetBeans 16 no desenvolvimento de aplicações web

PHP  8.1,  é  preciso  instalar  alguns  softwares,  na  seguinte  ordem,  em  seu  sistema

operacional: 

 1º) XAMPP.

 2º) Java SE Development Kit (JDK 17).

 3º) Apache NetBeans 16.

2.1 XAMPP

O XAMPP é um software livre e open-source, e é também o ambiente de desenvolvimento

PHP mais popular. Com o XAMPP é possível ter, em poucos minutos, um ambiente de

desenvolvimento  PHP 8.1  completo  e  de fácil  utilização.  Através  dele,  instalamos  os

principais componentes (Apache, MariaDB, PHP) de uma vez só.

O XAMPP é mantido pela Apache Friends. Para saber mais sobre a Apache Friends,

acesse https://www.apachefriends.org (acessado em 10 dez 2022).

2.1.1 Instalação em Windows 10 / 11

Para fazer a instalação do XAMPP no Windows, execute os seguintes passos:

1º) Acesse https://sourceforge.net/projects/xampp/files (acessado em 10 dez 2022).

2º) Clique no diretório com o nome XAMPP Windows e depois clique no diretório com o

nome 8.1.12.

3º) Clique xampp-windows-x64-8.1.12-0-VS16-installer.exe, você será redirecionado a

uma página de download, e então o download do arquivo iniciará automaticamente.

Arquivo de instalação para Windows: xampp-windows-x64-8.1.12-0-VS16-installer.exe

4º) Entre no diretório de Downloads, clique com o botão direito sobre o arquivo baixado e
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depois “Executar como administrador”. Caso apareça a seguinte mensagem, proceda da

seguinte maneira:

1. Clique em “OK” e em seguida cancele a instalação.

2. Clique no menu Iniciar. No campo de pesquisa, digite UAC.

3. Clique em “Alterar Configurações de Controle de Contas de Usuário”.

4. Na janela exibida, mova para baixo, em “Nunca notificar”.

5. Clique em OK, reinicie o computador e continue a partir do 5º passo.

 
5º) Entre no diretório de Downloads, clique com o botão direito sobre o arquivo baixado e

depois “Executar como administrador”. Então siga com o processo de instalação:

1. Tela inicial do processo de instalação, clique em Next para continuar.

2. Selecione os componentes a serem instalados (conforme imagem abaixo) e clique

em Next para continuar.
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3. Definição do local de instalação (não alterar), clique em Next para continuar.

4. Definição de idioma do XAMPP, não altere, clique em Next para continuar.
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5. Confirmação de que está tudo pronto para iniciar a instalação, clique em Next para

continuar.

6. Progresso de instalação, aguarde.
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7. Instalação concluída com sucesso, desmarque a caixinha e clique em Finish

6º) Para iniciar o XAMPP no Windows 10 / 11, clique no menu Iniciar, digite no campo de

pesquisa “xampp” e tecle “Enter” (quando aparecer ícone do XAMPP).
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Tela inicial do painel de controle do XAMPP Windows

7º) Para iniciar o servidor Apache, local onde rodam os scripts PHP, execute os seguintes 

procedimentos:

1. Para iniciar o servidor Apache, clique em Start.

2. Na primeira vez que iniciar o servidor Apache, será solicitado a permissão para

acesso a redes privadas e redes públicas por parte do servidor Apache. Marque a

caixinha em “Redes privadas, como minha rede doméstica ou corporativa” e clique

em “Permitir acesso”.
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3. Após clicar em Start no servidor Apache, o painel de controle habilitará o protocolo

de  comunicação  entre  navegador  e  servidor,  conforme  imagem  abaixo,  sendo

Porta 80 para HTTP e Porta 443 para HTTPS.

4. Abra seu navegador (Firefox, Edge, Chrome, outros) e digite  http://localhost/, se

aparecer  uma  página  semelhante  a  esta  abaixo,  seu  servidor  Apache  está

funcionando corretamente.
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8º) Para iniciar o servidor de banco de dados, execute os seguintes procedimentos:

1.  Para iniciar o servidor de banco de dados, inicie o servidor Apache (7º passo),

clique em Start (abaixo do Stop).

2. Na  primeira  vez  que  iniciar  o  servidor  de  banco  de  dados,  será  solicitado  a

permissão para acesso a redes privadas e redes públicas. Marque a caixinha em

“Redes privadas, como minha rede doméstica ou corporativa” e clique em “Permitir

acesso”.
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3. Após clicar em Start no servidor de banco de dados, o painel de controle habilitará

a Porta 3306 para a comunicação com o banco de dados.

4. Abra  seu  navegador  (Firefox,  Edge,  Chrome,  outros)  e  digite

http://localhost/phpmyadmin/, se aparecer uma página semelhante a esta abaixo,

seu servidor de banco de dados está funcionando corretamente.
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Observação:

 A primeira seta exibe a versão do servidor de banco de dados e a segunda

exibe a versão do servidor Apache, e também a versão do PHP.

2.1.2 Instalação em Linux (Debian, Ubuntu e derivados)

Para fazer a instalação do XAMPP no Linux, execute os seguintes passos:

1º) Acesse https://sourceforge.net/projects/xampp/files (acessado em 10 dez 2022).

2º) Clique no diretório com o nome XAMPP Linux e depois clique no diretório com o

nome 8.1.12.

3º)  Clique xampp-linux-x64-8.1.12-0-installer.run,  você  será  redirecionado  a  uma

página de download, e então o download do arquivo iniciará automaticamente;

Arquivo de instalação do XAMPP para Linux: xampp-linux-x64-8.1.12-0-installer.run

4º) Após o download, abra o terminal de comandos Linux e digite cada comando (a partir

do $) a seguir separadamente e tecle “Enter” para executá-lo:
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1. cd Downloads/ - Este comando acessa o diretório Downloads a partir do diretório

do usuário do sistema, nesse caso, diretório daniel. 

2. ls - Este comando lista todos os arquivos e diretórios que o diretório Downloads 

possui, nesse caso listou, xampp-linux-x64-8.1.12-0-installer.run

3. sudo  chmod  755  xampp-linux-x64-8.1.12-0-installer.run -  Este  comando  dá

permissão  para  o  usuário  executar  o  arquivo xampp-linux-x64-8.1.12-0-

installer.run, é necessário informar a senha.

4. ls - Com o comando ls novamente podemos ver que o arquivo xampp-linux-x64-

8.1.12-0-installer.run está em destaque e com as devidas permissões, portanto

agora podemos executá-lo.

5. sudo ./xampp-linux-x64-8.1.12-0-installer.run -  Este  comando é  utilizado para

executar esse tipo de arquivo e só funcionará possuir as permissões necessárias.

É preciso estar no diretório onde este arquivo se encontra. Se necessário informe a

senha.

Após o último comando siga com o processo de instalação:

1. Início do processo de instalação, clique em Next para continuar.
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2. Selecione os componentes a serem instalados e clique em Next para continuar.

3. Definição do local de instalação, clique em Next para continuar.
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4. Confirmação de que está tudo pronto para iniciar a instalação, clique em Next para

continuar.

5. Progresso de instalação, aguarde.
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6. Instalação concluída com sucesso, desmarque a caixinha e clique em Finish.

5º)  Abra o terminal de comandos Linux e digite cada comando (a partir do $) a seguir

separadamente e tecle “Enter” para executá-lo:

1. cd /opt/lampp/ - Este comando acessa o local onde o XAMPP foi instalado.
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2. ls -  Este  comando lista,  nesse caso,  todos os  arquivos e  diretórios  que estão

dentro do diretório lampp. 

3. sudo chmod 777  htdocs/ -  Este comando dá permissão completa de leitura e

escrita para o diretório htdocs, é necessário informar a senha.

6º) Para iniciar o XAMPP, abra o terminal de comandos Linux e digite cada comando (a

partir do $) a seguir separadamente e tecle “Enter” para executá-lo:

1. cd /opt/lampp/ - Este comando acessa o local onde o XAMPP foi instalado.

2. sudo ./manager-linux-x64.run - Este comando é utilizado para executar o painel

de controle do XAMPP. É preciso estar dentro do diretório lampp. Se necessário

informe a senha.

Após o último comando a seguinte tela aparecerá:

Tela inicial do painel de controle do XAMPP Linux
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7º) Para iniciar o servidor Apache, local onde rodam os scripts PHP, execute os seguintes

procedimentos:

1. Para iniciar o servidor Apache, clique em Manage Servers na tela inicial do painel

de controle, depois em Apache Web Server e, por fim, em clique Start.

2. Após clicar em Start no servidor Apache, o painel de controle deverá parecer como

a imagem abaixo. 

3. Abra seu navegador (Firefox, Chrome, outros) e digite http://localhost/, se aparecer

uma  página  semelhante  a  esta  abaixo  seu  servidor  Apache  está  funcionando

corretamente.
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8º) Para iniciar o servidor de banco de dados, execute os seguintes procedimentos:

1. Para iniciar o servidor de banco de dados, inicie o servidor Apache (7º passo),

clique em MySQL Database, em seguida clique em Start.

2. Após clicar em Start  no servidor de banco de dados, o painel de controle deverá

parecer como a imagem abaixo.

3. Abra  o  seu  navegador  (Firefox,  Chrome,  Opera,  outros)  e  digite

http://localhost/phpmyadmin/, se aparecer uma página semelhante a esta abaixo,

seu servidor de banco de dados está funcionando corretamente. 

Observação:

 A primeira seta exibe a versão do servidor de banco de dados e a segunda

exibe a versão do servidor Apache, e também a versão do PHP.
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2.2 Java SE Development Kit (JDK)

O Apache NetBeans 16 suporta o JDK 11 e JDK 17. 

O JDK é  software  que oferece um ambiente de desenvolvimento para construção de

aplicações e componentes escritos na linguagem de programação Java. E inclui também

uma ferramenta que permite a execução de aplicações (programas) Java, como o Apache

NetBeans 16 por exemplo, chamada de Java Runtime Environment.

O  JDK  é  propriedade  da  Oracle  America  e  é  sem  custo  para  uso  pessoal  e  de

desenvolvimento. 

Detalhes da licença: 

 https://www.oracle.com/downloads/licenses/javase-license1.html   (Em inglês,

acessado em 10 dez 2022)

2.2.1 Instalação em Windows 10 / 11

Para fazer a instalação do JDK 17 (17.0.5) no Windows 10 / 11, execute os seguintes

passos:

1º) Acesse https://www.oracle.com/java/technologies/javase/jdk17-archive-downloads.html

(acessado em 10 dez 2022).

2º) Procure por Windows x64 Installer e clique no arquivo correspondente para fazer o

download. Caso apareça um popup, aceite os termos para fazer o download (talvez seja

necessário ter uma conta Oracle).

Arquivo de instalação para Windows 10 / 11: jdk-17.0.5_windows-x64_bin.exe

3º) Entre no diretório de Downloads, clique com o botão direito sobre o arquivo baixado e

depois “Executar como administrador”. Então siga com o processo de instalação:

1. Início processo de instalação, clique em Next para continuar.
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2. Definição do local de instalação (não alterar), clique em Next para continuar.

3. Progresso de instalação, aguarde.
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4. Instalação concluída com sucesso, clique em Close.

2.2.2 Instalação em Linux (Debian, Ubuntu e derivados)

Para fazer a instalação do JDK 17 no Linux, vamos utilizar o  OpenJDK 17 (versão de

código aberto do JDK 17).
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Abra  o  terminal  de  comandos  Linux  e  digite  cada  comando (a  partir  do  $)  a  seguir

separadamente e tecle “Enter” para executá-lo:

1. sudo  apt  install  openjdk-17-jdk  - Este  comando,  após  sua  autorização  /

confirmação, irá instalar automaticamente o OpenJDK 17 e suas dependências. 

2. java --version -  Este comando exibe a versão específica do OpenJDK que foi

instalado.

2.3 Apache NetBeans 16

No capítulo 1 conhecemos um pouco sobre o Apache NetBeans 16 e a partir do próximo

capítulo  o  conheceremos  e  utilizaremos  na  prática,  contudo,  para  prosseguir  com  a

instalação é importante que você tenha instalado corretamente, o XAMPP e JDK.

Observação:

 No Windows 10 / 11 será instalado o Apache Netbeans 16 customizado para PHP,

já no Linux será instalado a versão completa.

2.3.1 Instalação em Windows 10 / 11

Para fazer a instalação do Apache NetBeans 16 customizada para PHP no Windows 10 /

11, execute os seguintes passos:

1º) Acesse https://netbeans.apache.org/download/nb16/ (acessado em 10 dez 2022).

2º) Clique em Apache-NetBeans-16-bin-windows-x64.exe e faça o download.

3º) Entre no diretório de Downloads, clique com o botão direito sobre o arquivo baixado e

depois “Executar como administrador”. Então siga com o processo de instalação:

1. Progresso de inicialização do instalador, aguarde.
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2. Início do processo de instalação, clique em Customize…

3. Selecione o que será instalado (conforme imagem abaixo) e clique em OK.
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4. Confira o que foi selecionado e clique Next para continuar. 

5. Marque a caixinha para aceitar os termos de uso e clique em Next para continuar.
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6. O primeiro campo corresponde ao local de instalação do Apache NetBeans 16 e o

segundo campo corresponde ao local de instalação do JDK 17 (será reconhecido

automaticamente, se seguiu corretamente a instalação do JDK 17), clique em Next

para continuar.
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7. Desmarque a caixinha Check for Updates e clique em Install para continuar. 

8. Progresso da instalação, aguarde.
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9. Instalação concluída com sucesso, clique em Finish.

4º) Para  iniciar  o  Apache  NetBeans  16,  clique  no  menu  Iniciar,  digite  no  campo  de

pesquisa “Apache NetBeans 16” e tecle “Enter”. Se preferir, dê um duplo clique no ícone

do Apache NetBeans 16 na área de trabalho.

Tela de carregamento do Apache NetBeans 16
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Tela inicial do Apache NetBeans 16 para Windows 10 / 11

2.3.2 Instalação em Linux (Debian, Ubuntu e derivados)

Para fazer a instalação do Apache NetBeans 16 completo no Linux, execute os seguintes

passos:

1º) Acesse https://netbeans.apache.org/download/nb16/ (acesso em 10 dez 2022);

2º) Clique em apache-netbeans_16-1_all.deb e faça o download;

3º) Após o download, abra o terminal de comandos Linux e digite cada comando (a partir

do $) a seguir separadamente e tecle “Enter” para executá-lo:

1. cd Downloads/ - Este comando acessa o diretório Downloads a partir da pasta do

usuário do sistema, nesse caso, diretório daniel. 

2. ls -  Este comando lista todos os arquivos e diretórios que o diretório Downloads

possui, nesse caso listou, apache-netbeans_16-1_all.deb.
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3. sudo dpkg -i  apache-netbeans_16-1_all.deb -  Este  comando é  utilizado para

executar  arquivos  tipo  .deb.  Informe a  senha,  a  instalação  iniciará  e  terminará

automaticamente. 

4º) Para iniciar o Apache NetBeans 16, dê um duplo clique no ícone do Apache NetBeans

16 na área de trabalho (Pode variar  de  acordo com a distro  que está  utilizando)  ou

procure por “Apache NetBeans 16” em seus aplicativos instalados.

Tela de carregamento do Apache NetBeans 16
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Tela inicial do Apache NetBeans 16
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Capítulo 3 – Conhecendo o Apache NetBeans 16

Ao iniciarmos o Apache NetBeans 16,  independente do sistema operacional  utilizado,

vemos sua tela inicial (2.3 Apache NetBeans 16). Entretanto, a seguir veremos a interface

gráfica do Apache NetBeans 16 a partir  de um projeto chamado  helloworld (veremos

como criá-lo em Capítulo 5 – Criação e deploy do projeto em um servidor local). Nela será

possível ver em detalhes as principais áreas (conheceremos mais sobre essas áreas logo

adiante) da interface do Apache NetBeans 16, sendo:

1. Menubar (Barra de menus)

2. Toolbars (Barras de ferramentas)

3. Projects window (Janela de projetos)

4. Files window (Janela de arquivos)

5. Services window (Janela de serviços)

6. Editor (Editor de código)

7. Navigator window (Janela de navegação)

8. Output window (Janela de saída)

9. Component Palette window (Paleta de componentes)

10.Properties window (Janela de propriedades)

Detalhes da interface gráfica do Apache NetBeans 16 para Windows 10 / 11:
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Detalhes da interface gráfica do Apache NetBeans 16 para Linux:
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Observação: 

 A disposição dos elementos da interface, inclusive teclas de atalho, do Apache 

NetBeans 16 são iguais em Windows 10 / 11 e Linux.

3.1 Menubar (Barra de menus)

A barra de menus do Apache NetBeans 16 é composta por:  File,  Edit,  View, Navigate,

Source,  Refactor,  Run,  Debug,  Profile  (disponível  na  versão  completa  do  Apache

NetBeans 16),  Team,  Tools,  Window  e  Help.  A seguir será detalhada cada opção de

menu da versão customizada para PHP do Apache Netbeans 16.

3.1.1 File

O menu File, conforme a imagem abaixo, possui as seguintes opções: 
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 New Project:  Adiciona/Criar  um projeto.  (Veremos como criar  um projeto mais

adiante)

 New File:  Adiciona/Criar um arquivo. Escolha o tipo de arquivo e estrutura que

precisará.

 Open Project: Abre um projeto, selecionado de algum diretório.

 Open Recent Project:  Abre um projeto recente, fechado recentemente na janela

de projetos (3.3 Projects window).

 Close Project:  Fecha o projeto que está selecionado. Para ver qual projeto está

selecionado, observe o nome do projeto que está entre os parênteses em Close

Project (helloworld).

 Close Other Projects: Fecha todos os projetos na janela de projetos (3.3 Projects

window),  exceto  o  projeto  que  está  selecionado.  Para  ver  qual  projeto  está

selecionado, observe o nome do projeto que está entre os parênteses em Close

Project (helloworld).

 Close All Projects:  Fecha todos os projetos na janela de projetos (3.3 Projects

window).

 Open File: Abre um arquivo, selecionado de algum diretório.

 Open Recent File: Abre um arquivo recente (fechado recentemente no editor de

códigos – 3.6 Editor).

 Project Groups: Gerenciamento de grupos de projetos.

 Project Properties:  Abre as propriedades do projeto que está selecionado. Para

ver o projeto que está selecionado, observe o nome do projeto que está entre os

parênteses em Project Properties (helloworld).

 Import Project: Importa um projeto para a janela de projetos (3.3 Projects window)

a  partir  de  um  arquivo  compactado  (.zip).  (É  preciso  ser  um  projeto  que  foi

criado/exportado com o Apache NetBeans 16)

 Export Project: Exporta o projeto selecionado na janela de projetos (3.3 Projects

window) em arquivo compactado (.zip).  (Escolher local onde irá salvá-lo)

 Save: Salva o arquivo que foi aberto, modificado e está selecionado no editor de

códigos (3.6 Editor).

 Save As: Salva o arquivo que foi aberto, modificado e está selecionado no editor

de códigos (3.6 Editor) em um novo arquivo. (Escolher local onde irá salvá-lo)

 Save All: Salva todos os arquivos que foram modificados e estão abertos no editor

de códigos (3.6 Editor).
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 Page Setup:  Ajustes  para impressão como:  tamanho de papel  a  ser  utilizado,

orientação (retrato ou paisagem) e tamanho das margens.

 Print: Imprime o código do arquivo selecionado na janela de projetos (3.3 Projects

window) ou janela de arquivos (3.4 Files window).

 Print to HTML: Imprime o código do arquivo selecionado na janela de projetos (3.3

Projects window) ou janela de arquivos (3.4 Files window) no formato HTML.

 Exit: Encerra o Apache NetBeans 16. 

3.1.2 Edit

O menu Edit, conforme a imagem abaixo, possui as seguintes opções: 

 Undo: Desfaz  alguma  modificação  feita  no  arquivo  via  editor  de  códigos  (3.6

Editor).

 Redo: Refaz o que foi desfeito com o Undo.
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 Cut: Recorta o que foi selecionado no arquivo via editor de códigos (3.6 Editor).

 Copy: Copia o que foi selecionado no arquivo via editor de códigos (3.6 Editor).

 Paste: Cola o que foi copiado via Copy ou área de transferência do sistema.

 Paste Formatted:  Cola o que foi copiado via  Copy ou área de transferência do

sistema.

 Paste from History: Exibe uma lista com as últimas cópias, para selecionar o que

será colado.

 Paste as Lines: Cola o que foi  copiado via  Copy ou área de transferência do

sistema sobre múltiplos cursores.

 Delete: Deleta o que foi selecionado no arquivo via editor de códigos (3.6 Editor).

 Select All: Seleciona tudo que está no arquivo via editor de códigos (3.6 Editor).

 Select Identifier: Seleciona o texto onde o cursor está posicionado.

 Find Selection: Procura e destaca no arquivo atual, que está aberto no editor de

códigos (3.6 Editor), tudo o que corresponde ao que foi selecionado.

 Find Next: Destaca no arquivo atual, que está aberto no editor de códigos (3.6

Editor), o próximo termo dentre os que foram encontrados. 

 Find Previous: Destaca no arquivo atual, que está aberto no editor de códigos (3.6

Editor), o termo anterior dentre os que foram encontrados.

 Find: Abre uma barra de texto para digitar e procurar algo no arquivo atual, que

está aberto no editor de códigos (3.6 Editor).

 Replace: Abre uma barra de texto para digitar o que será procurado (Find What) e

outra barra de texto para digitar que substituirá (Replace) o que foi encontrado pelo

Find What. 

 Find  Usages:  Procura  usos  do  código  selecionado  (funções,  classes  e  etc)  e

indica o local exato.

 Find in Projects: Procurar por texto, objetos, funções e etc no projeto atual ou em

todos os projetos que possuir.

 Replace in Projects: Substitua texto, objetos, funções e etc no projeto atual ou em

todos os projetos que possuir.

 Start Macro Recording: Inicia a gravação de uma Macro que contém movimentos

do cursor e pressionamentos de teclas.   (Cria um atalho para movimentos que

sempre executa no Apache NetBeans 16)

 Stop Macro Recording: Para a gravação da Macro e abre a opção de salvá-la.
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3.1.3 View

O menu View, conforme a imagem, possui as seguintes opções: 

 Editors:  Escolher  entre  exibir  o  código  fonte  ou  histórico  (ver  alterações

realizadas).

 Split: Opção  para  dividir  (duas  áreas  de  edição)  tela  horizontalmente,

verticalmente ou retornar para padrão.

 Code Folds: Opções para dobras (blocos) de código.

 IDE Log:  Exibe  logs  do Apache  NetBeans  16 na  janela  de  saída  (3.8  Output

window).

 Toolbars: Opções para customizar, criar, exibir e resetar as Barras de ferramentas

(3.2 Toolbars). Por padrão, algumas opções de toolbars já vem selecionadas para

exibição.

 Show Editor Toolbars: Exibe a Barras de ferramentas do editor de códigos (3.6

Editor). 

 Show Line Numbers: Exibe o número de cada linha no editor de códigos (3.6

Editor).

 Show Non-printable Characters: Exibe caracteres não imprimíveis (representa

“espaços” e “enters”).
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 Show Breadcrumbs:  A partir  da  posição do cursor,  exibe  o  caminho de  tags

HTML, exibe o caminho de classes e funções PHP e etc, em uma barra abaixo do

editor de códigos (3.6 Editor).

 Show Indent Guide Lines: Exibe uma linha de indentação (linha que liga o início e

fim da dobra).

 Show Inline Hints: Exibe dicas.

 Show Diff Sidebar: Exibe uma marcação colorida ao lado da linha de indentação

no arquivo aberto no editor de códigos (3.6 Editor), que indica alguma modificação,

adição ou conflito no controle de versão utilizado (Git, Mercurial, Subversion). 

 Show  Versioning  Labels: Exibe  uma  etiqueta  (marcação  textual)  de  status

(arquivo modificado, ignorado, modificado e etc) ao lado de cada arquivo na janela

de projetos (3.3 Projects window) e janela de arquivos (3.4 Files window).

 Synchronize Editor  with  Views: O arquivo que está  aberto  e  selecionado no

editor de códigos (3.6 Editor) ficará selecionado também na janela de projetos (3.3

Projects window) e janela de arquivos (3.4 Files window). Útil  para identificar a

localidade do arquivo quando se tem muitos arquivos abertos no editor de códigos

(3.6 Editor).

 Show Only  Editor: Exibe  apenas  o  editor  de  códigos  (3.6  Editor)  e  barra  de

menus. 

 Full Screen: Exibe Apache NetBeans em tela cheia. Para sair da tela cheia mova o

mouse até topo e aparecerá a barra de menus, clique em Full Screen novamente.

3.1.4 Navigate

O menu Navigate, conforme a imagem abaixo, possui as seguintes opções: 
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 Go to File: Procura um arquivo pelo nome e abre-o. 

 Go to Type: Procura uma classe ou interface pelo nome e abre-a. 

 Go To Symbol: Procura por um símbolo e abre-o.

 Go to Test/Tested class: Procura por teste específico e abre-o.

 Go to  Previous Window:  Seleciona a  última janela  aberta  antes  selecionar  a

janela atual. 

 Go to Source: Função desabilitada, utilize o Go to Declaration.

 Go to Declaration:  Vai para a declaração do item (classe, objeto, variável e etc)

sob o cursor.

 Go to Super Implementation: Função desabilitada, utilize o Go to Declaration.

 Last Edit Location: Retorna para o local onde ocorreu a última edição/alteração.

 Back: Navega de volta (retorna) em sua interação com Apache NetBeans 16. Não

altera o arquivo.

 Forward:  Navega para frente (avança) em sua interação com Apache NetBeans

16. Não altera o arquivo.

 Go to Line: Vai para a linha especificada.

 Toggle Bookmark: Define um marcador para uma determinada linha de código.

 Bookmark History  Popup Next:  Abre um  popup com todos os  marcadores e

seleciona qual o próximo marcador a ser aberto e conferido.
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 Bookmark History Popup Previous: Abre um popup com todos os marcadores e

selecione marcado anterior a ser aberto e conferido.

 Next Error: Exibe a próxima linha que contém a indicação de erro.

 Previous Error: Exibe a linha anterior que contém a indicação de erro.

 Select in Projects:  Abre a janela de projetos (3.3 Projects window) e identifica o

arquivo dentro dela.

 Select in Files: Abre a janela de arquivos (3.4 Files window) e identifica o arquivo

dentro dela.

 Select in Favorites: Abre a janela de favoritos (Favorites window) e identifica o

arquivo dentro dela. 

3.1.5 Source

O menu  Source  (está diretamente ligado ao arquivo aberto e selecionado no editor de

códigos (3.6 Editor), conforme a imagem abaixo, possui as seguintes opções: 

 Format: Formata (melhora aspecto visual do código) o código todo ou a parte que
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foi selecionada de acordo com as especificações definidas na aba Formatting da

categoria Editor dentro do menu de opções (Options).

 Remove Trailing Spaces: Remove os espaços a direita. (Final da linha de código)

 Shift  Left:  Move a(s)  linha(s)  selecionada(s)  ou  recua  alguns  espaços  para  a

esquerda.

 Shift Right: Move a(s) linha(s) selecionada(s) ou avança alguns espaços para a

direita.

 Move Up: Move a(s) linha(s) ou parte selecionada para cima.

 Move Down: Move a(s) linha(s) ou parte selecionada para baixo.

 Move Code Element Up: Move a(s) linha(s) ou parte selecionada para cima.

 Move Code Element Down: Move a(s) linha(s) ou parte selecionada para baixo.

 Duplicate Up: Duplica a(s) linha(s) ou parte selecionada para cima.

 Duplicate Down: Duplica a(s) linha(s) ou parte selecionada para baixo.

 Toggle Comment: Comenta a(s) linha(s) selecionada(s).

 Complete Code: Abre um popup com opções para o preenchimento automático de

código. (Muito importante essa ferramenta)

 Insert Code: Reconhece o contexto do seu código e abre um popup opções para

gerar automaticamente métodos e estruturas como construtores, getters e setters.

 Fix Code:  Exibe dicas do editor de códigos (3.6 Editor). É possível exibir a dica

utilizando essa função,  quando uma lâmpada aparecer  no  lugar  do  número da

linha.

 Fix  Uses:  Gera  as  instruções  de  importação  requeridas  pelas  classes

especificadas  no  arquivo.  Corrige  o  operador  use (PHP)  para  os  namespaces

(PHP) utilizados.

 Show  Method  Parameters:  Exibe  os  parâmetros  necessários  para  utilizar

determinado método/função. 

 Show Documentation: Exibe a documentação de algum item onde o cursor está

posicionado.

 Insert Next Matching Word: Gera a próxima palavra, já usada em outra parte do

seu código, conforme digita os caracteres iniciais. 

 Insert Previous Matching Word: Gera a palavra anterior, já usada em outra parte

do seu código, conforme digita os caracteres iniciais.

 Inspect: Inspecionar o código. (É preciso configurá-lo corretamente nas opções de

configuração do Apache NetBeans 16).

 Scan for External  Changes:  Procura por  alterações externas (fora do Apache
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NetBeans 16), geralmente feitas em outros editores de código.

3.1.6 Refactor

O menu Refactor, conforme a imagem abaixo, possui as seguintes opções: 

 Rename: Renomeia classe, variável, método ou campos do seu código fonte. 

 Move: Não permitido no contexto do PHP, esse comando serve para mover uma

classe de um pacote Java para outro.

 Copy: Não permitido no contexto do PHP, esse comando serve para copiar uma

classe de um pacote Java para outro.

 Safely Delete: Antes de deletar verificar se o arquivo está sendo referenciado.

 Extract Inline Style: Extrai o atributo style de uma tag HTML, cria um id ou class

para essa tag e implementa o CSS de forma interna ou externa (é preciso ter o

arquivo css já criado) automaticamente.

3.1.7 Run

O menu Run, conforme a imagem abaixo, possui as seguintes opções: 
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 Run  Project:  Executa  o  projeto  selecionado  (nome  do  projeto  aparece  entre

parênteses) ou executa o projeto definido como principal (Main Project) em Set

Main Project.

 Test  Project:  Inicia  unidade  de  teste  para  o  projeto.  (Para  utilizar  é  preciso

configurar)

 Set  Project  Configuration: Configuração  do  projeto.  Você  pode  manter  as

configurações de quando criou o projeto ou pode customizá-las.

 Set Project Browser: Escolhe navegador padrão para o projeto.

 Set Main Project: Seleciona algum projeto como sendo o principal (Main Project).

Ao utilizar Run Project, o projeto definido como principal será sempre executado,

independentemente se outro projeto estiver selecionado. 

 Run File: Executa o arquivo que está selecionado.

 Test  File:  Inicia  unidade  de  teste  para  o  arquivo  selecionado.  (Para  utilizar  é

preciso configurar)

 Check File: Verifica o arquivo XML selecionado.

 Validate File: Valida o arquivo XML selecionado.

 Repeat  Build/Run:  Executa  o  projeto  selecionado  atualmente  mais  uma  vez.

(Função desabilitada, utilize Run Project)

 Stop Build/Run: Para a execução do projeto. (Função desabilitada)

3.1.8 Debug

O menu  Debug  (veremos como instalar /  configurar o Xdebug para utilizar este menu

corretamente,  em  8.1  Instalando  o  Xdebug),  conforme  a  imagem  abaixo,  possui  as

seguintes opções: 
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 Debug Project:  Depura  o  projeto  selecionado (nome do  projeto  aparece entre

parênteses)  ou depura o projeto definido como principal  (Main Project)  em  Set

Main Project (visto em 3.1.8 Run). 

 Debug File: Inicia sessão de depuração do arquivo que está selecionado.

 Debug Test File: Inicia teste de depuração do arquivo que está selecionado.

 Attach Debugger: Anexa um depurador para uma sessão de depuração remota;

 Finish Debugger Session: Finaliza sessão de depuração.

 Pause:  Função desabilitada, pois a execução do depurador (Xdebug) é pausada

sempre que há um ponto de interrupção (Breakpoint).

 Continue: Continua a depuração até o próximo ponto de interrupção (Breakpoint)

ou final do programa é atingido.

 Step  Over:  Executa  uma  linha  de  código  do  programa.  Se  a  linha  for  uma

chamada de método, executa-o inteiro (sem exibi-lo) e então para com a execução.

 Step  Over  Expression:  Utilize  Step  Over. Função  desabilitada  para  PHP.  É

utilizada em aplicações Java.

 Step Into: Executa uma linha de código do programa. Se a linha for uma chamada
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de método, executa o programa até primeira declaração do método e então para

com a execução.

 Step  Into  Next  Method: Utilize Step  Intro.  Função  desabilitada  para  PHP.  É

utilizada em aplicações Java

 Step Out:  Executa uma linha de código do programa. Se a linha de código fizer

parte de uma chamada de método (através de um Step Into), executa as linhas

restantes  do  método  e  retorna  (saí  do  método)  o  controle  para  programa

novamente, e então para com a execução. 

 Run to Cursor:  Executa uma linha de código do programa onde o cursor está

posicionado e então para com a execução.

 Apply Code Changes: Função desabilitada para PHP, essa função é utilizada em

aplicações Java, na qual é possível fazer alterações no código sem interromper ou

reiniciar a depuração da aplicação. 

 Stack: Função desabilitada para PHP, essa função é executada automaticamente

durante a depuração do projeto e exibe a pilha de chamadas (para visualizá-las

acesse Window > Debugging > Call Stack).

 Toggle Line Breakpoint: Adiciona um ponto de interrupção ou remove-o na linha

onde o cursor está posicionado. 

 New Breakpoint:  Adiciona  um ponto  de  interrupção  em uma linha ou  método

específico.

 New Watch: Marca uma variável específica para observar e avaliar (para visualizá-

la  acesse  Window > Debugging >  Watches).  (É  preciso ativar  essa opção nas

configurações do PHP no Apache NetBeans 16) 

 Evaluate Expression: Função desabilitada para PHP. Utilizada para aplicações

Java.

3.1.9 Team

O menu  Team  (veremos mais adiante como utilizar este menu corretamente utilizando

sistema de controle de versões Git (local) e GitHub (remoto), conforme a imagem abaixo,

possui as seguintes opções: 
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 Shelve Changes: Permite arquivar / esconder modificações que ainda não foram

enviadas (via commit ou pull) para repositório Git local ou remoto.

 Git: Opções para sistema de controle de versão Git.

 Mercurial: Opções para sistema de controle de versão Mercurial.

 Subversion: Opções para sistema de controle de versão Subversion.

 History: Exibe histórico de alterações de determinado arquivo. Pode se comparar

o arquivo  atual  com suas versões anteriores (uma de cada vez)  ou selecionar

alguma versão do arquivo e compará-la com a versão anterior.

 Find Tasks: Procura por tarefas em um repositório de tarefas, que pode ser local

ou remoto. 

 Report Tasks: Especifica detalhes da tarefa.

 Create Build Job: Cria um trabalho em um servidor de construção Hudson.

3.1.10 Tools

O menu Tools, conforme a imagem abaixo, possui as seguintes opções: 
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 Apply Diff Patch: Aplica as mudanças contidas no patch escolhida para o arquivo

ou pasta selecionada.

 Diff: Compara (pode ser textualmente ou graficamente) dois arquivos selecionados

no Apache NetBeans 16.

 Add to  Favorites:  Adiciona arquivos ou pastas  aos favoritos  (para  visualizá-la

acesse Window > Favorites).

 Open in Terminal: Abre o arquivo no terminal do Apache NetBeans 16. (É preciso

ter cygwin instalado)

 Create/Update Tests:  Cria/Atualiza uma unidade de teste utilizando o  Selenium

Framework.

 Ant Variables: Gerenciador de variáveis de ambiente Ant

 Libraries: Gerenciador e bibliotecas Ant.

 Servers: Habilita a implantação de servidores, por exemplo Glassfish.

 Cloud Providers: Habilita a implantação de servidores cloud.

 Template:  Gerenciador  de  modelos  (conjunto  de  vários  tipos  e  estruturas  de

arquivos prontos para utilizar no projeto). Para inserir arquivo a partir de um modelo

acesse na barra de menus: File > New File.

 DTDs and XML Schemas: Exibe todos os DTDs (definição de tipo de documento)

e esquemas (regras de validação) XML registrados atualmente.

 Palette: Gerenciar de paletas de componentes.
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 Plugins: Exibe os plugins que estão instalados, os plugins disponíveis para baixar

(opção para adicionar  de fonte externa também),  atualizações disponíveis  e  os

plugins baixados.

 Options:  Edita  as  configurações  do  Apache  NetBeans  16.  (Veremos

detalhadamente essa opção no próximo capítulo).

3.1.11 Window

O menu Window, conforme a imagem abaixo, possui as seguintes opções: 

 Projects: Exibe a janela de projetos (3.3 Projects window).

 Files: Exibe a janela de arquivos (3.4 Files window).

 Favorites: Exibe a janela de favoritos (Favorites window).

 Services: Exibe a janela de serviços (3.5 Services window).

 Navigator: Exibe a janela de navegação (3.7 Navigator window).

 Action Items: Exibe a janela de itens de ação (Action Items window).

 Tasks: Exibe a janela de tarefas (Tasks window).

 Output: Exibe a janela de saída (3.8 Output window).
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 Editor: Exibe o editor de códigos (3.6 Editor).

 Debugging: Opção para exibir janelas específicas para depuração. 

 Web: Opção para exibir janelas para auxiliar no desenvolvimento web.

 IDE Tools: Opção exibir janelas específicas de ferramenta do Apache NetBeans

16. 

 Configure Window: Configurações relativas a janela que está selecionada como

maximizar, minimizar e entre outras.

 Reset Windows: Reseta todas as janelas para o padrão.

 Close Window: Fecha uma janela que está selecionada.

 Close All Documents: Fecha todos os documentos (arquivos) que estão abertos

no editor de códigos (3.6 Editor).

 Close  Other  Documents:  Fecha  todos  os  documentos  (arquivos)  que  estão

abertos no editor de códigos (3.6 Editor), exceto o que está selecionado.

 Document Groups: Gerencia grupos de documentos (arquivos). 

 Documents: Exibe um popup com documentos (arquivos) do projeto, e permite

que você possa salvar, alternar e fechar documentos (arquivos) abertos.

3.1.12 Help

O menu Help, conforme a imagem abaixo, possui as seguintes opções: 

 Search:  Busca  rapidamente  algo  dentro  do  Apache  NetBeans  16,  exceto

documentos (arquivos) de algum projeto. Essa opção aparece ao lado direito da

barra de menus do Windows 10 / 11 e Linux. 

 Online Docs and Support: Redireciona para página de suporte e documentação.

 Keyboard Shortcuts Card: Abre um arquivo PDF que contém atalhos de teclado

para modelos de códigos e para funções do Apache NetBeans 16.  Atenção: A

melhor forma de encontrar atalhos de teclado para modelos de código é  Tools >
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Options > Editor > Code Templates. E a melhor forma de encontrar atalhos de

teclado para funções do Apache NetBeans 16 é Tools > Options > Keymap.

 Report  Issue:  Redireciona  para  uma  página  oficial  para  reportar  os

problemas/bugs  encontrados  e  também  ver  os  problemas  que  já  foram

solucionados.

 Check  for  Updates:  Procura  atualizações  para  o  Apache  NetBeans  16

manualmente.

 Start Page: Exibe a página inicial do Apache NetBeans 16.

 About : Exibe informações sobre a versão do produto, versão do Java (incluído no

JDK),  versão  do  Runtime  (incluído  no  JDK),  sistema  operacional,  diretório  do

usuário (dados do perfil para Apache NetBeans 16) e diretório de cache. A primeira

imagem a abaixo corresponde ao About no Windows 10 / 11 e a segunda imagem

corresponde ao About no Linux.

3.2 Toolbars (Barras de ferramentas)

As barras de ferramentas são gerenciadas a partir do menu View e são compostas por

atalhos (ícones) que permitem uma ação rápida do usuário no acesso às funcionalidades,

já vistas nos menus anteriores, do Apache NetBeans 16. É possível customizá-las do jeito

que quiser, sendo possível adicionar novos ícones as barras de ferramentas que já vem

por padrão ou criar outras barras de ferramentas de acordo com sua necessidade. 

 Para customizar ou criar: View > Toolbars > Customize

 Para resetar  para o padrão (deleta todas modificações): View > Toolbars >

Reset Toolbars

 Para exibir ou ocultar: View > Toolbars > (marque / desmarque a toolbar)
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 Para diminuir os atalhos (ícones): View > Toolbars > Small Toolbar Icons

3.3 Projects window (Janela de projetos)

A janela de projetos do Apache NetBeans 16 exibe todos os projetos que estão abertos,

entretanto, se os projetos estiverem separados por grupos, serão exibidos somente os

projetos pertencentes ao grupo selecionado.

 Para exibir: Window > Projects

 Para configurar (a janela deve estar selecionada): Window > Configure Window

> (escolha uma opção)

 Para fechar (a janela deve estar selecionada): Window > Close window

 Observação: A pasta  Source Files  (abaixo no nome do projeto)  corresponde a

pasta original (raiz) do projeto localizada no seu sistema operacional

Para mais informações sobre janelas no Apache NetBeans 16, vá para 3.1.11 Window.

3.4 Files window (Janela de arquivos)

A janela de arquivos do Apache NetBeans 16 exibe exatamente a estrutura de arquivos

de todos os projetos que estão abertos na janela de projetos, ou seja, exibe o diretório

original  de cada projeto,  incluindo arquivos e pastas que não aparecem na janela de

projetos.

 Para exibir: Window > Files

 Para configurar (a janela deve estar selecionada): Window > Configure Window

> (escolha uma opção)

 Para fechar (a janela deve estar selecionada): Window > Close window

Para mais informações sobre janelas no Apache NetBeans 16, vá para 3.1.11 Window.

3.5 Services window (Janela de serviços)

A  janela  de  serviços  do  Apache  NetBeans  16  exibe  os  serviços  disponíveis  como

conexões com databases (banco de dados), gerenciamento de servidores, web servers e
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entre outros.

 Para exibir: Window > Services

 Para configurar (a janela deve estar selecionada): Window > Configure Window

> (escolha uma opção)

 Para fechar (a janela deve estar selecionada): Window > Close window

Para mais informações sobre janelas no Apache NetBeans 16, vá para 3.1.11 Window.

3.6 Editor (Editor de código)

A janela de editor de código, é sem dúvida a mais importante do Apache NetBeans 16,

pois é  através dela que você desenvolverá a sua aplicação PHP. O editor de código

possui  uma  barra  de  ferramentas  própria  com  atalhos  (ícones)  de  algumas

funcionalidades já vistas nos menus  Edit,  View,  Navigate e  Source.  Através do menu

Source  você  tira  o  máximo  proveito  do  Editor  de  código,  utilizando  por  exemplo,  o

autopreenchimento  de  código  (Source  >  Complete  Code),  a  inserção  de  estruturas

código automaticamente a partir do reconhecimento de contexto (Source > Insert Code),

a indentação do código (Source > Format) e entre outras. Confira mais funcionalidades

do menu Source.

 Para exibir: Window > Editor

 Para configurar (a janela deve estar selecionada): Window > Configure Window

> (escolha uma opção)

 Para fechar (a janela deve estar selecionada): Window > Close window

Para mais informações sobre janelas no Apache NetBeans 16, vá para 3.1.11 Window.

3.7 Navigator window (Janela de navegação)

A janela de navegação do Apache NetBeans 16 exibe uma estrutura específica de acordo

com o código do arquivo que está selecionado. Por exemplo, se for um arquivo HTML

exibirá  todas as  tags respeitando a  hierarquia,  já  se  for  uma classe PHP,  exibirá  as

propriedades, funções e etc, respeitando também a hierarquia. 

 Para exibir: Window > Navigator
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 Para configurar (a janela deve estar selecionada): Window > Configure Window

> (escolha uma opção)

 Para fechar (a janela deve estar selecionada): Window > Close window

Para mais informações sobre janelas no Apache NetBeans 16, vá para 3.1.11 Window.

3.8 Output window (Janela de saída)

A janela de saída é uma janela multiabas que exibe mensagens do Apache NetBeans 16, como:

IDE Logs, erros de compilação, Git logs, logs do navegador e entre outros.

 Para exibir: Window > Output

 Para configurar (a janela deve estar selecionada): Window > Configure Window

> (escolha uma opção)

 Para fechar (a janela deve estar selecionada): Window > Close window

Para mais informações sobre janelas no Apache NetBeans 16, vá para 3.1.11 Window.

3.9 Component Palette window (Janela de paleta de componentes)

A janela de paleta de componentes do Apache NetBeans 16 exibe uma lista de componentes

disponíveis para serem adicionados rapidamente, de acordo com a sua necessidade, ao editor de

códigos. 

 Para exibir: Window > IDE Tools > Palette

 Para configurar (a janela deve estar selecionada): Window > Configure Window

> (escolha uma opção)

 Para fechar (a janela deve estar selecionada): Window > Close window

Para mais informações sobre janelas no Apache NetBeans 16, vá para 3.1.11 Window.

3.10 Properties window (Janela de propriedades)

A janela propriedade do Apache NetBeans 16 exibe informações (nome, tipo (extensão), tamanho,

data de modificação e caminho onde está armazenado) sobre o arquivo que está selecionado. Na

janela de propriedade é possível alterar o nome e o tipo (extensão) do arquivo.
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 Para exibir: Window > IDE Tools > Properties

 Para configurar (a janela deve estar selecionada): Window > Configure Window

> (escolha uma opção)

 Para fechar (a janela deve estar selecionada): Window > Close window

Para mais informações sobre janelas no Apache NetBeans 16, vá para 3.1.11 Window.
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Capítulo 4 – Configurações do Apache NetBeans 16

É  possível  alterar  qualquer  uma  das  opções  que  forem  configuráveis  no  Apache

NetBeans  16  por  meio  da  janela  de opções  (Options).  A  janela  de  opções  possui  a

mesma interface para Windows 10 / 11 e Linux. 

 Para abrir a janela de opções no Windows 10 / 11 e Linux: Tools > Options

A janela  de opções é  composta  pelas  categorias:  General,  Editor,  Fonts & Colors,

Keymap, Java, HTML/JS, PHP, C/C++, Team, Appearance, Miscellaneous. E algumas

dessas  categorias  possuem  abas  para  configurações  adicionais.  Sendo  assim,  para

aplicar uma ou várias alterações no Apache NetBeans 16 basta clicar em Apply na janela

de opções.

4.1 General

A categoria  General, conforme imagem abaixo, permite: definir navegador padrão (Web

Browser) e configurar proxy (Proxy Settings). 
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4.2 Editor

A categoria  Editor,  possui  abas (conforme imagem abaixo)  que permitem visualizar  /

habilitar / incluir / desabilitar recursos do editor de códigos (3.6 Editor). Dentre essas abas

podemos destacar: Folding, Formatting, Code Completion, Code Templates.

4.2.1 Folding

A aba Folding, possui um recurso (habilitado por padrão na instalação), que serve para

visualizar / habilitar / desabilitar a manipulação das dobras (blocos) de código. É possível

configurar  um  padrão  para  todas  a  linguagens  permitidas  ou  configurar  para  cada

linguagem separadamente.

 Para acessar/alterar as configurações da aba Folding: Tools > Options > Editor

> Folding.

 Para manipular as dobras (blocos) de código:  View > Code Folds > (escolha

uma opção, que pode ser para uma dobra específica ou para todas do documento).

Você também pode manipular  a  dobra (bloco)  de código uma por  uma,  conforme as

imagens abaixo:

1. Para recolher um bloco de código, clique em - (indicado pela seta vermelha).
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2. Para expandir um bloco de código, clique em + (indicado pela seta vermelha).

4.2.2 Formatting 

A  aba  Formatting é  possível  visualizar  /  configurar  a  formatação  padrão  (espaços,

indentação,  alinhamento,  funções,  condicionais  e  etc)  do  código  de  acordo  com  a

linguagem que se está utilizando. Estas configurações serão utilizadas globalmente, ou

seja, por todos os projetos que forem criados. 

 Para  acessar/alterar  as  configurações  de  formatação  (globais)  da  aba

Formatting: Tools > Options > Editor > Formatting

 Para  acessar/alterar  as  configurações  de  formatação  de  um  projeto

específico  (o  projeto  deve  estar  selecionado): File  >  Project  Properties  >

Formatting

 Para  aplicar  as  configurações  definidas  em  Formatting  (global  ou  projeto

específico) em algum arquivo  do  projeto  (deve  estar  aberto  no  editor  de

código): Source > Format

4.2.3 Code Completion

A aba Code Completion serve para visualizar / habilitar / desabilitar recursos, em todas

as linguagens ou uma linguagem específica, para deixar a função de autopreenchimento

mais inteligente e gerar código rapidamente.

 Para  modificar  as  configurações  autopreenchimento  de  código: Tools  >

Options > Editor > Code Completion

 Para utilizar o autopreenchimento de código: Source > Code Completion

4.2.4 Code Templates

O Apache NetBeans 16 possui vários modelos de código para várias linguagens e  podem

ser utilizados a partir de abreviações pré estabelecidas. A aba Code Templates permite

visualizar/ incluir / modificar / excluir modelos de código.
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 Para utilizar algum modelo de código: (digite a abreviação) + tecla Tab

4.3 Fonts & Colors

A  categoria Fonts  &  Colors,  possui  abas  (conforme  imagem  abaixo)  que  permitem

visualizar / modificar um perfil (Profile) de fontes e cores que serão utilizadas para tornar

a leitura do código mais agradável e de fácil compreensão para o desenvolvedor. 

Observações:

 As  abas  exibirão  as  configurações  de  fontes  e  cores  de  acordo  com  o  perfil

(Profile) selecionado. 

 Alterar a aparência (tema) da interface do Apache NetBeans 16 altera também o

perfil de fontes e cores.

 Na aba Syntax você pode visualizar / modificar o esquema de fontes e a cores para

uma linguagem específica também.
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4.4 Keymap

A categoria  Keymap,  conforme imagem abaixo, permite visualizar /  modificar /  atribuir

atalhos (Shortcuts) a todas ações (Actions) permitidas no Apache NetBeans 16.

Observações:

 Os atalhos (Shortcuts) corresponde ao perfil (Profile) que selecionado.

 Utilize  o  campo  Search  para  pesquisar  qual  atalho  (Shortcut)  corresponde  ao

nome da ação (Action) pesquisada.

 Utilize  o  campo  Search  in  Shortcuts  para  pesquisar  qual  ação  (Action)

corresponde ao atalho (Shortcut) preenchido.

4.5 Java

A categoria Java, conforme as imagens abaixo (1ª Windows 10 / 11 e 2ª Linux), permite

visualizar / modificar as configurações do Apache Ant. 
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Categoria Java - Apache NetBeans 16 para Windows 10 / 11

Categoria Java - Apache NetBeans 16 para Linux (Debian, Ubuntu e derivados)
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4.6 HTML / JS

A categoria HTML / JS, possui abas (conforme imagem abaixo) que permitem adicionar

recursos poderosos ao HTML e JavaScript, como Bower, Pré processadores CSS (SASS

E LESS), GULP, NodeJs.

4.7 PHP

A categoria PHP, conforme as imagens abaixo (1ª - Windows 10 / 11 e 2ª - Linux), contém

abas  que  permitem  visualizar  /  adicionar  recursos  PHP,  como  parametrização  de

depuração  (Debugging)  para  integrar  Apache  NetBeans  16  com  Xdebug,  adicionar

ferramentas de análises de código (Code Analysis) como Code Sniffer e Mess Detector, e

também  adicionar  ferramentas  e  frameworks  (Frameworks  &  Tools)  como  Twig,

Composer, Zend, Symphony e entre outros.

Observações:

 Na aba  General,  de  acordo com o sistema operacional  utilizado  (ver  imagens

abaixo), adicione o caminho para o interpretador do PHP (PHP Interpreter) e logo

abaixo em Open Result In marcar as caixinhas Output Window e Web Browser. 

 É  muito  importante  indicar  o  interpretador  corretamente  para  que  não  ocorra
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nenhum problema na configuração do ambiente de desenvolvimento e também no

desenvolvimento de suas aplicações. 

Categoria PHP- Apache NetBeans 16 para Windows 10 / 11

Categoria PHP - Apache NetBeans 16 para Linux (Debian, Ubuntu e derivados)
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4.8 C/C++

A  categoria  C/C++ adiciona  recursos  inteligentes  ao  Apache  NetBeans  16  para  a

linguagem C/C++, basta definir CCLS e/ou clangd.

4.9 Team

A categoria  Team,  possui  abas  (conforme imagem abaixo)  que permitem visualizar  /

modificar as configurações do recurso de equipe do Apache NetBeans 16.
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4.10 Appearance

A categoria Appearance, possui abas (conforme imagem abaixo) que permite visualizar /

modificar as configurações de comportamento abas de documentos (Documents Tabs) e

janelas  (Windows),  e  também  aparência  (Look  and  Feel)  da  interface  do  Apache

NetBeans 16.

Observações: 

 Para alterar o tema clique em  Look and Feel,  escolha uma opção de tema em

Preferred and Feel, clique em Apply e reinicie o Apache NetBeans 16.

 Os temas escuros, possuem a palavra Dark no nome.

4.11 Miscellaneous

A categoria Miscellaneous, possui abas (conforme imagem abaixo), permitem visualizar /

modificar configurações opcionais,  como tipos de arquivos ignorados e associados ao

Apache NetBeans 16, e também padrão de fonte e cores da janela de saída (3.8 Output

window).
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Capítulo 5 – Criação e deploy do projeto em um 
servidor local

Todo desenvolvimento de alguma aplicação no Apache NetBeans 16 tem que acontecer

dentro de um projeto, que é o agrupamento dos arquivos e as configurações sobre as

quais eles são construídos, executados e depurados.

O Apache NetBeans 16 disponibiliza alguns modelos de projetos para diferentes tipos de

linguagens e fornece um assistente para criá-los. Sendo assim, seguiremos com a criação

de um projeto na linguagem de programação PHP. 

Criaremos  o  projeto  helloworld,  que  foi  utilizado  como  exemplo  para  apresentar  a

interface  gráfica  do  Apache  NetBeans  16  no  Capítulo  3  –  Conhecendo  o  Apache

NetBeans 16.  Siga os passos abaixo:

1º) Inicie o servidor Apache no seu sistema operacional através do painel de controle do

XAMPP, conforme já visto na instalação em 2.1 XAMPP. 

2º) Inicie o Apache NetBeans 16 (conforme já visto em  2.3 Apache NetBeans 16), clique

no menu File, em seguida clique na opção New Project. 

3º) Siga a etapas do assistente de criação de projetos, conforme abaixo:

1. Esta  etapa  serve  para  escolher  o  modelo  de  projeto.  Clique  em  PHP  (seta

vermelha à esquerda) e em seguida clique em PHP Application (seta vermelha à

direita). Após a escolha clique em Next para continuar. 
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2. Esta etapa serve para definir o nome do projeto (Project Name), pasta de arquivos

do projeto (Sources Folder), versão do PHP para dicas (PHP Version), codificação

padrão (Default  Encoding)  e  opção para salvar  os  metadados em um diretório

separado.  Em  Project  Name digite  helloworld  e  em  Sources Folder  digite  o

nome da pasta após htdocs (se não aparecer o caminho até esta pasta clique em

Browser… e navegue até ela e selecione-a) onde os arquivos do projeto ficará

salvo. Clique em Next para continuar. 

Observação:

 As imagens a seguir mostram (respectivamente) esta etapa em Windows

10 / 11 e Linux.

Etapa 2 da criação de um projeto Apache NetBeans 16 no Windows 10 / 11
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Etapa 2 da criação de um projeto Apache NetBeans 16 no Linux

3. Esta etapa serve para configurar o deploy (implantação) do projeto, que poderá ser

em servidor local (XAMPP) ou em um servidor remoto (hospedagem). Utilizaremos

nosso servidor local (XAMPP) e no Capítulo 9 veremos como fazer deploy em um

servidor remoto. Em  Run As, escolha a opção  Local Web Server e em  Project

URL defina a  URL do projeto que deverá conter  http://localhost/helloworld (nome

exato da pasta onde estão os arquivos do projeto) e depois clique em Next. 

75

https://github.com/idanielnorberto


Aprenda Apache NetBeans 16 para PHP 8.1 [eBook]. Feito por Daniel Norberto

4. Esta etapa serve para adicionar algum framework ao seu projeto, clique em Next

para continuar.

5. Esta  etapa  serve  para  adicionar  algum  pacote  ao  seu  projeto  via  Composer

(veremos como utilizá-lo no Apache NetBeans 16 no próximo capítulo), clique em

Finish para concluir a criação de um projeto.

6. Após a conclusão do assistente, seu projeto estará disponível na janela de projetos

(3.3 Projects window), conforme imagem abaixo.
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4º) Para executar o projeto helloworld, siga as etapas abaixo: 

1. Com o projeto selecionado, clique em  na barra de ferramentas ou clique em

Run (na barra de menus) seguido de Run Project.

2. O projeto será aberto no navegador escolhido como padrão na categoria General

no menu de opções.

Observação: 

 Ao executar o projeto helloworld, o navegador exibirá apenas a página em

branco,  pois  não  nenhum comando de  saída  foi  inserido  no  documento

index.php, como echo ou print por exemplo.
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Capítulo 6 – Composer no Apache NetBeans 16 

O Composer é uma ferramenta utilizada para o gerenciamento de dependências no PHP.

Dependências é um pacote ou biblioteca, criado por terceiros, que será utilizado em sua

aplicação. Você declara o pacote ou biblioteca que sua aplicação “depende” (necessita),

então o Composer gerencia-o para você (instala / atualiza a dependência em um diretório

chamado vendor).

Observações: 

 Um  pacote  ou  biblioteca  escolhida  podem também  depender  de  vários  outros

pacotes ou bibliotecas, mas não se preocupe, pois o Composer se encarregará

gerenciar todas essas dependências necessárias.

 É importante que você tenha conhecimentos em Composer.  E para saber tudo

sobre  o  Composer,  acesse  a  documentação  oficial  (em  inglês)

https://getcomposer.org/doc/ (acessado em 17 dez 2022).

 Para consultar / utilizar pacotes gratuitos que são instalados via Composer, acesse

o repositório principal (em inglês) Packagist (https://packagist.org). (Acessado em

17 dez 2022)

 Você também poderá adicionar seu próprio código para que seja automaticamente

carregado pelo Composer. Veja mais detalhes sobre  autoload na documentação

oficial.

6.1 Habilitando o Composer no Apache NetBeans 16

Para habilitar o Composer no Apache NetBeans 16, siga os passos abaixo:

1º) Acesse https://getcomposer.org/download/ (Acessado em 17 dez 2022);

2º)  Role  a  página  até  Manual  Download e  clique  em Latest  Stable para  fazer  o

download  da  última  versão  mais  estável.  Após  o  download,  arquivo  composer.phar

estará disponível no diretório de Downloads do seu sistema operacional.

3º) Abra o Apache NetBeans 16 no Windows 10 / 11 ou Linux, clique no menu Tools,

clique em Options, clique na categoria PHP, clique na aba Frameworks & Tools e por

último clique em Composer.
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4º)  Clique  em Browse...,  conforme  imagem  abaixo,  para  adicionar  o  caminho

completo até o arquivo composer.phar, baixado no 2º passo. 

Observação: 

 A  seguir  optamos  por  manter  o  arquivo  composer.phar  no  diretório  de

Downloads, mas você pode alterar o local do arquivo sem problema algum, desde

que caminho completo seja definido corretamente no Apache NetBeans 16.

5º)  As imagens a seguir representam o caminho já adicionado no Apache NetBeans 16

em Windows 10 / 11 e Linux respectivamente. Clique em Apply e em seguida clique em

OK para concluir.

Configuração do Composer no Apache NetBeans 16 para Windows 10 / 11
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Configuração do Composer no Apache NetBeans 16 para Linux

Observações:

 Vendor: Define o nome do “fornecedor” do pacote.

 Author name: Define o nome do autor do pacote.

 Author e-mail: Define o email do autor do pacote

 Desmarque a caixinha Ignore “vendor” directory…

 Os valores dos campos preenchidos Vendor, Author name, Author e-mail, serão

inseridos  no  arquivo  gerado  (composer.json)  através  do  comando  Init  do

Composer a partir do Apache NetBeans 16.

 É importante ter conhecimentos em Composer e em arquivos do tipo  .json, pois,

apesar  do  Apache  NetBeans  16  auxiliar  na  utilização  do  Composer,  pode  ser

necessário inserir informações manualmente no arquivo composer.json.

6.2 Conhecendo o Composer no Apache NetBeans 16

Após clicar com  o botão direito sobre o nome de algum projeto na janela de projetos (3.3

Projects window), pare o mouse sobre Composer e aparecerá as seguintes opções do

Composer  (conforme imagem abaixo):
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Observação:

 Ao  executar  alguma  opção  (comando)  do  Composer,  verá  todo  progresso  de

execução na janela de saída (3.8 Output window).

6.2.1 Add Dependency

Abre uma janela (conforme imagem abaixo) para procurar e adicionar as dependências ao

seu projeto.
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1. Campo para buscar algum pacote.

2. Exibe os pacotes encontrados que são relacionados ao termo buscado.

3. Exibe detalhes do pacote que está selecionado.

4. Exibe as versões disponíveis (para escolher) do pacote que está selecionado.

5. Adiciona o pacote ao projeto. Você pode adicionar a dependência selecionada ao

seu  projeto  como  “require”  (dependência  essencial  ao  seu  projeto)  ou  como

require-dev  (dependência  que  será  utilizada  somente  no  ambiente  de

desenvolvimento).

Observação:

  Para manter a janela de adição de dependências aberta, basta marcar a caixinha

Keep this window opened.

6.2.2 Init

Cria,  se  ainda não  existir,  o  arquivo  de  configuração do Composer  (composer.json)

automaticamente com as informações que foram inseridas em  Vendor,  Author name,

Author e-mail, já visto em 6.1 Habilitando Composer no Apache NetBeans 16.
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6.2.3 Install (dev)

Efetua a leitura do arquivo composer.json e instala dependências definidas em “require”

e “require-dev” no diretório  vendor. Após a instalação com sucesso é gerado também

um arquivo composer.lock.

6.2.4 Install (no-dev)

Efetua  a  leitura  do  arquivo  composer.json  e  instala  no  diretório  vendor  apenas  as

dependências que estiverem definidos em “require”. 

6.2.5 Update (dev)

Efetua a leitura do arquivo composer.json e atualiza todas as dependências que estão

definidas em “require” e “require-dev”. Atualiza também o arquivo composer.lock.

6.2.6 Update (no-dev)

Efetua a leitura do arquivo composer.json e atualiza apenas as dependências que estão

definidas em “require” e remove do diretório vendor as dependências que estão definidas

em “require-dev”. Atualiza também o arquivo composer.lock.

6.2.7 Update Autoloader (dev)

Efetua a leitura do arquivo composer.json e atualiza apenas os arquivos de autoload.

6.2.8 Update Autoloader (no-dev)

Efetua a leitura do arquivo  composer.json  e atualiza apenas os arquivos de  autoload

(desconsiderando os pacotes definidos em require-dev).

6.2.9 Validate

Efetua a validação do arquivo composer.json.

6.2.10 Self Update

Efetua a atualização da versão do Composer.phar.
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6.3 Utilizando o Composer no Apache NetBeans 16

Para exemplificar  a  utilização do Composer  no Apache NetBeans 16,  siga os passos

abaixo:

1º) Crie um novo projeto chamado hellocomposer, conforme as instruções passadas no

Capítulo 5 – Criação e deploy do projeto em um servidor local.

  
2º)  Clique com o botão direito sobre o nome do projeto  hellocomposer, pare o mouse

sobre  Composer  e  clique  em  Init.  Será  gerado  automaticamente  o  arquivo

composer.json, conforme a imagem abaixo.

3º)  Vamos adicionar um pacote chamado “cocur/slugify” (Saiba todos os detalhes em:

https://packagist.org/packages/cocur/slugify - acessado em 20 dez 2022) que transforma

uma frase, por exemplo, “O Brasil é grande” em “o-brasil-e-grande”. 

Clique com  o botão direito sobre o nome do projeto hellocomposer, pare o mouse sobre

Composer, clique em Add Dependency, busque por cocur/slugify, selecione a versão

(instale sempre que possível a versão mais estável para o seu projeto, neste exemplo

será  instalada a  versão  v4.3.0), clique  em  Require  (vamos supor  que esse seja  um

pacote essencial para o nosso projeto) e aguarde o processo de instalação. Confira a

imagem abaixo. 
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Adicionando um pacote chamado “cocur/slugify”

4º)  Vamos adicionar  também um pacote chamado “phpunit/phpunit”  (Saiba todos os

detalhes em: https://packagist.org/packages/phpunit/phpunit - acessado em 20 dez 2022)

que fornece uma estrutura de testes para PHP. 

Clique com o botão direito sobre o nome do projeto hellocomposer, pare o mouse sobre

Composer,  clique  em Add  Dependency,  busque  por  phpunit/phpunit,  selecione  a

versão (instale sempre que possível  a  versão mais estável  para o seu projeto,  neste

exemplo será instalada a versão 9.5.27), clique em Require (dev) (vamos supor que esse

seja um pacote essencial apenas para o ambiente de desenvolvimento do nosso projeto)

e aguarde o processo de instalação. Confira a imagem abaixo. 
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Adicionando um pacote chamado “phpunit/phpunit”

5º)  Após os dois passos anteriores, a estrutura do projeto e o arquivo  composer.json

deverá se parecer com a imagem abaixo.

Arquivo composer.json após o 3º e 4º passo

Observações;

 Como pode ver, no diretório vendor, o Composer instalou todas as dependências

necessárias para o projeto.
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 Você pode desinstalar (remover do diretório  vendor) as dependências do projeto

definidas  em  “require-dev”  no  arquivo  composer.json, executando  a  opção

Update (no-dev), saiba mais sobre esse comando em 6.2.6 Update (no-dev).

6º) Para finalizar, vamos testar / utilizar a dependência “cocur/slugify”.  Abra o arquivo

index.php, digite o código (conforme a 1ª imagem abaixo), execute-o (Run > Run project)

e veja o resultado (conforme 2ª imagem abaixo).

Utilização da dependência “cocur/slugify” no arquivo index.php

Resultado do arquivo index.php no navegador! A dependência funcionou corretamente.

Observação:

 Para utilizar corretamente os pacotes que for escolher, é importante ler o README

na  página  do  pacote,  pois  lá  contém  as  instruções  de  uso  e  outros  detalhes

importantes.

 Lembre-se de iniciar o servidor Apache.
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Capítulo 7 – Git e GitHub no Apache NetBeans 16 

Git é um sistema open-source de controle de versão, que nos permite controlar todo o

histórico de uma determinada aplicação,  sendo possível  voltar  em qualquer  ponto do

histórico (commits realizados) para saber como a aplicação estava naquele determinado

momento.  A  aplicação  que  utiliza  Git  é  armazenada  (após  cada  commit)  em  um

repositório que pode ser local ou remoto. Em um repositório local você conseguirá todo

poder de versionamento que o Git oferece, entretanto o repositório Git ficará apenas no

ambiente local (computador pessoal, empresa e etc..), não sendo possível trabalhar em

equipe. Já em um repositório remoto, existe a possibilidade de trabalhar com equipe, na

qual cada membro copia o repositório Git para o seu repositório local e depois de efetuar

modificações necessárias envia-o novamente para o repositório remoto.

GitHub  é  um  serviço  online  para  o  armazenamento/hospedagem  de  repositórios  Git

(acessados  remotamente).  Além  de  funcionar  como  um  excelente  hospedagem  de

repositórios  Git,  o  GitHub  permite  a  colaboração  e  compartilhamento  de  projetos

(repositórios Git) entre os desenvolvedores.

Observação: 

 É importante que você tenha conhecimentos em Git. Para saber tudo sobre o Git,

acesse a documentação oficial (em inglês) https://git-scm.com/doc. (Acessado em

20 dez 2022)

 É importante que você tenha conhecimentos e uma conta em GitHub. Para saber

mais sobre o GitHub, acesse site https://github.com (em inglês) e para um melhor

aprendizado  acesse  https://skills.github.com (em inglês).  (Acessado  em 20  dez

2022)

7.1 Como iniciar um repositório Git local

Para iniciar um repositório Git local, siga os passos abaixo:

1º) Na janela de projetos (3.3 Projects window), selecione algum projeto que ainda não

está sendo versionado com Git.

2º) Clique com o botão direito sobre o nome do projeto selecionado, pare o mouse sobre

88

https://skills.github.com/
https://github.com/idanielnorberto
https://github.com/
https://git-scm.com/doc


Aprenda Apache NetBeans 16 para PHP 8.1 [eBook]. Feito por Daniel Norberto

Versioning  e  clique  em Initialize  Git  Repository.  Ou também pode  clicar  no  menu

Team, depois clique em Git e em seguida clique em Initialize Repository.

3º) Na janela que abrirá, selecione o caminho (deverá apontar para o mesmo diretório da

pasta raiz do projeto selecionado no 1º passo) onde o repositório Git será criado e clique

em OK.

Observações:

● O diretório .git será criado e ocultado dentro do diretório definido no 3º passo. O

diretório  .git será  o  repositório  local  e  guardará  as  informações  referentes  ao

versionamento do seu projeto. 

● Você verá processo de inicialização na janela de saída (3.8 Output window). E na

janela de projetos (3.3 Projects window) os arquivos do projeto estarão marcados

com a cor verde  (pare o mouse sobre o arquivo / diretório e verá seu estado como

“Added”),  que  mostra  que  novos  arquivos  estão  disponíveis  para  serem

adicionados ao repositório Git. 

● Após  a  iniciar  um  repositório  Git  você  pode  adicionar  arquivos  para  serem

monitorados (comando  add) ou fazer commit desses arquivos (passa a fazer  o

monitoramento dos arquivos e cria um ponto no histórico de versão, com todas

modificações realizadas até aquele momento) para o repositório Git.

7.2 Conhecendo o Git no Apache NetBeans 16

Após clicar com o botão direito sobre o nome de algum projeto que está sendo versionado

pelo Git na janela de projetos (3.3 Projects window), pare o mouse sobre Git e aparecerá

as seguintes opções do Git (conforme imagem abaixo):
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Observação:

 Ao  executar  alguma  opção  (comando)  do  Git,  você  verá  todo  progresso  de

execução na janela de saída (3.8 Output window).

7.2.1 Show Changes

Permite  ver  e  gerenciar  as  mudanças  que  ocorreram  no  repositório  Git.  Também  é

possível  identificar  essas mudanças na janela de projetos (3.3 Projects window) e na

janela de arquivos (3.4 Files window).

Observações:

 A cor verde indica que o arquivo ou diretório ainda não existe no repositório Git, a

cor azul indica que o arquivo ou diretório foi modificado.

 A cor vermelha indica que o arquivo ou diretório está em conflito com alguma outra

versão de si mesmo.

 A cor que está com risco da mesma cor indica que arquivo ou diretório não será

90

https://github.com/idanielnorberto


Aprenda Apache NetBeans 16 para PHP 8.1 [eBook]. Feito por Daniel Norberto

incluído na execução de um commit.

 A cor  cinza indica  que o arquivo  ou diretório  está sendo ignorado e  não será

incluído no versionamento.

7.2.2 Diff

Permite comparar  graficamente,  conforme imagem abaixo,  as  versões de um mesmo

arquivo lado a lado, enfatizando as suas diferenças.

Comparação, usando comando Diff, das modificações feitas no arquivo index.php 

7.2.3 Add

Permite  rastrear  arquivos  recentes  do  projeto  e  que  não  estão  no  repositório  Git,  e

também modificar arquivos que já estão no repositório Git. O comando Add adiciona os

arquivos  em  uma  área  do  Git  chamada  de  Index,  que  pode  ser  considerada  uma

“preparação” dos arquivos para entrar no próximo comando de commit, que vai enviá-los

ao repositório para uma outra área chamada HEAD. 

Observação:

 Você pode executar  diretamente um  commit,  sem precisa executar  o  comando

Add. 

7.2.4 Commit 

Esta  opção,  conforme  a  imagem  abaixo,  abre  uma  janela  para  no  auxiliar  na  execução  do
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commit, permitindo enviar os arquivos / diretórios para o repositório Git.

1. Mensagem de texto para identificar o commit.

2. Define o autor do commit.

3. Área para seleção dos arquivos a serem incluídos no commit.

4. Opcional, especifica e modifica tarefas relacionadas ao commit. 

5. Botão de commit.

7.2.5 Checkout

Possui duas opções:

 Checkout Revision:  Permite verificar alguma branch existente, de acordo nome

selecionado no campo revision. Atualiza os arquivos do projeto de acordo com a

branch selecionada.

92

https://github.com/idanielnorberto


Aprenda Apache NetBeans 16 para PHP 8.1 [eBook]. Feito por Daniel Norberto

 Checkout  Files: Atualiza  os  arquivos  do  projeto  de  acordo  com  o  caminho

selecionado no campo revision. O caminho padrão aponta para o último commit

realizado.

Observação:

 A revision especificada exibirá as seguintes informações do commit: ID, autor, data

e mensagem.
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7.2.6 Revert Modifications 

Reverte as modificações feitas no seu projeto, através das seguintes opções (conforme

imagem abaixo):

 Revert Uncommitted Changes Both in Working Tree and Index: Deleta todas

as modificações que não sofreram commit, retornando os arquivos / diretórios para

o estado atual na HEAD. Possui uma opção para deletar arquivos / diretórios que

ainda não sofreram commit.

 Revert Uncommitted Changes in Working Tree to the State in Index: Deleta

todas  as  modificações  que  não  sofreram  commit,  retornando  os  arquivos  /

diretórios para o estado atual na Index. Possui uma opção para deletar arquivos /

diretórios que foram criados no projeto, mas não foram adicionados (Add) ao Index.

 Revert  Only  Uncommitted  Changes  in  Index  to  HEAD: Deleta  todas  as

modificações  na  Index  que  não  sofreram  commit,  retornando  os  arquivos  /

diretórios para o estado atual na HEAD.

7.2.7 Show Annotations

Exibe o ID e o autor do commit no arquivo versionado que está aberto no editor de código

(margem esquerda do Editor, ao lado do número das linhas). Ao clicar sobre o ID são

exibidos, conforme a imagem abaixo, as seguintes informações do commit: ID, autor, data

e a mensagem.

Annotations
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7.2.8 Show History

Exibe,  em uma  janela,  o  histórico  do  arquivo  versionado  para  encontrar  um  commit

específico.  Você pode buscar  arquivos  ou diretórios  pesquisando pela  mensagem do

commit, branch, autor do commit e entre outros.

7.2.9 Resolve Conflicts

Essa opção estará disponível quando houver um conflito em algum arquivo (ficará com

cor  vermelha)  do  repositório  Git.  A  imagem abaixo  apresenta  um conflito  no  arquivo

index.php, identificado após a execução de um merge (mescla). O conflito exibido no

index.php em (2) no qual há uma linha a mais de comentário em comparação com o

index.php em (1).  Você  deverá  escolher  (Accept)  o  que manterá  na versão final  do

arquivo index.php (3).

Observação:

 Pode ocorrer de existir vários conflitos em um mesmo arquivo.

7.2.10 Ignore

Possui duas opções: 

 Ignore: Essa opção serve  para  ignorar  arquivos ou  diretórios  adicionados  (cor

verde)  ao  projeto.  Os  arquivos  /  diretórios  ignorados  não  serão  incluídos  no
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repositório Git e também não serão afetados por comandos Git.

 Exclude from commit: Excluir arquivos ou diretórios (já existentes no Repositório

Git) de um commit.

7.2.11 Patches

Permite criar (Export Uncommitted Changes / Export Commit) patches para “distribuir”

as modificações realizadas no repositório Git.

Permite aplicar (Apply Diff Patch) os patches criados, para que não tenha que executar

modificações no repositório Git manualmente.

Observação:

 Essa opção é geralmente utilizada para equipes que não tenham um repositório Git

em comum, como um repositório Git remoto por exemplo.

7.2.12 Branch / Tag

Permite gerenciar Branches e Tags. Possui as seguintes opções:

 Create a Branch: Cria uma nova branch.

 Switch  To  Branch: Abre  uma  lista  com  todas  as  branches  disponíveis  para

escolher em qual branch trabalhará.

 Set Tracked Branch: Define uma branch para rastrear..

 Create Tag: Cria uma etiqueta (Tag) para identificar um commit específico.

 Manages Tags: Abre um gerenciador para as Tags criadas.

 Merge Revision: Faz a mesclagem de duas branches. Para utilizar: Em Revision

clique  em  Select  para  escolher  uma  branch.  Por  fim  clique  em  Merge.  Caso

ocorrer conflitos e tenha dúvidas sobre como resolver, dê uma olhada em  7.2.9

Resolve Conflicts.

 Rebase: Altera a base de uma branch a partir de outra branch. Para utilizar: Em

Rebase escolha a opção Current Branch to Any Destination e em Destination

Revision clique em Select para escolher uma branch. Por fim clique em Rebase.

 Cherry Pick: Permite selecionar commit de outra branch e aplicá-lo na branch que

estamos trabalhando. 
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7.2.13 Remote 

Possui as seguintes opções/comandos para trabalhar com repositório Git remoto:  

 Clone:  Abre  um assistente  para  auxiliar.  Faz  um  clone  de  um repositório  Git

remoto. (Veremos como clonar em 7.3.1 Clonando um repositório Git remoto)

 Fetch from Upstream: Pega, sem o auxílio / confirmação do assistente, todas as

modificações (commits)  que estão repositório Git  remoto,  mas não mescla com

repositório Git local. 

 Fetch:  Abre  um  assistente  (Fetch  from  Remote  Repository)  para  auxiliar  /

confirmar. Pega todas as modificações (commits) que estão repositório Git remoto,

mas não mescla com repositório Git local.  (Veremos em 7.3.2.1 Fetch)

 Pull from Upstream: Puxa, sem o auxílio / confirmação do assistente, todas as

modificações  (commits)  que  estão  repositório  Git  remoto  e  mescla  com  o

repositório Git local automaticamente.

 Pull: Abre um assistente (Pull from Remote Repository) para auxiliar / confirmar.

Puxa todas as modificações (commits) que estão repositório Git remoto e mescla

com o repositório Git local. (Veremos em 7.3.2.2 Pull)

 Push from Upstream: Empurra / Envia, sem o auxílio / confirmação do assistente,

todas as modificações (commits) que estão repositório Git local para o repositório

Git remoto.

 Push: Abre um assistente (Push from Remote Repository) para auxiliar / confirmar.

Empurra / Envia todas as modificações (commits) que estão repositório Git local

para o repositório Git remoto. (Veremos em 7.3.2.3 Push)

 Show Incoming for Repository: Exibe os commits de entrada para o repositório.

Exibe os commits no repositório remoto que entrarão repositório local, por meio

Fetch ou Pull.

 Show Outgoing for Repository: Exibe os commits de saída do repositório. Exibe

os commits no repositório local que entrarão no repositório remoto, por meio Push.

 Show Incoming for Selection: Exibe os commits de entrada relacionado ao que

está selecionado. Exibe os commits no repositório remoto que entrarão repositório

local, por meio Fetch ou Pull.

 Show Outgoing for Selection: Exibe os commits de saída relacionado ao que

está selecionado. Exibe os commits no repositório local que entrarão no repositório

remoto, por meio Push.
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7.2.14 Revert / Recover

A opção  Revert  abre um assistente, conforme imagem abaixo, para reverter / desfazer

modificações inseridas por meio de um commit. 

 1º Círculo vermelho:  Em  Revision você escolhe qual commit quer reverter. As

informações sobre o commit selecionado aparecerão logo abaixo.

 2º Círculo vermelho: Ativar essa opção (Commit Revert Changes) significa que

será gerado um novo commit para a ação de reverter um commit.

Observação:

 Apesar  de  reverter  um  commit  específico,  todo  o  histórico  de  commits  serão

mantidos. 

A opção Reset abre um assistente, conforme imagem abaixo, que permite retornar o seu
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repositório para um determinado commit.

 1º Círculo vermelho: Em Revision você escolhe para qual commit quer retornar.

As informações sobre o commit selecionado aparecerão logo abaixo.

 2º Círculo vermelho: Opções para complementar o Reset: 

○ Do not Modify Index or Working Tree (--soft): Retorna a HEAD para o

commit  selecionado,  mantendo  as  modificações  feitas  na  Index  e  na

estrutura do projeto.

○ Modify  Working  Tree  (--mixed): Retorna  a  HEAD  para  o  commit

selecionado, sobrescrevendo as modificações feitas na Index e mantendo as

modificações na estrutura do projeto. 

○ Update Index and Working Tree (--hard): Retorna a HEAD para o commit

selecionado, sobrescrevendo as modificações feitas na Index e na estrutura

do projeto. 

Observação:

 Todo  os  commits  executados  após  o  commit  selecionado  em  Revision serão

excluídos.
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7.2.15 Repository

Possui as opções:

 Open Configuration:  Abre o arquivo  config  e permite visualizar /  modificar as

configurações  de  um  repositório  específico.  O  arquivo  config  está  dentro  do

diretório  .git que se  encontra  no  diretório  raiz  de  todo projeto  que está  sendo

versionado pelo Git.

 Repository  Browser:  Exibe  as  branches  (local  ou  remota),  tags  e  outras

informações importantes sobre os Repositórios Git que foram iniciados (conforme

visto em 7.1 Como iniciar um repositório Git local) ou clonados (conforme visto em

7.3 Como clonar / modificar um repositório Git remoto (GitHub)).

 Open Global Configuration: Abre o arquivo .gitconfig e visualizar / modificar as

configurações globais do Git. O arquivo .gitconfig está dentro do diretório raiz do

usuário no sistema operacional.

7.2.16 Shelve Changes

Possui uma opção chamada Stash Changes, que ao clicar sobre ela, abre um assistente

(conforme imagem abaixo): 

 Stash  Changes:  As  modificações  efetuadas  em  arquivos  que  estão  sendo

rastreados e também as modificações na área de Index (Comando Add) que não

foram enviadas (via commit) para repositório Git, serão salvas para o uso posterior.

Marque a opção (Include Uncommitted Changes) para incluir os arquivos que

foram adicionados ao projeto mas que não estão sendo rastreados.
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 Shelve Changes:  Abre um assistente (conforme a imagem abaixo) que permite

arquivar (criar arquivo patch) as modificações efetuadas que não foram enviadas

(via commit) para repositório Git. É preciso definir o nome do patch (Patch Name) e

as opções (Options).

Assistente para arquivar (criar arquivo patch) as modificações efetuadas e que não foram

enviadas (via commit)

Observações:

 A opção Stash Changes  corresponde ao comando  git stash <complementos> e

armazena  as  modificações  em  uma  área  específica  do  repositório  Git,  dentro

diretório .git.

 A opção  Shelve Changes é uma função exclusiva do Apache NetBeans 16 que

armazena  as  modificações  em um arquivo  patch  no  diretório  chamado  patch-

storage que é específico do próprio Apache NetBeans 16 e definido no momento

de sua instalação (se seguiu corretamente a instalação o caminho até o diretório

patch-storage deverá ser parecido conforme a seguir).

○ Linux: /home/daniel/.netbeans/16/var/versioning/patch-storage/

○ Windows  10  /  11: C:\Users\Daniel\AppData\Roaming\NetBeans\16\var\

versioning\patch-storage

 Para recuperar uma  Stash Change: Team > Shelve Changes > Git Unstash >

(selecione qual recuperar)

 Para  recuperar  uma  Shelve  Change: Team  >  Shelve  Changes  >  Unshelve

Changes > (selecione qual recuperar)

7.3 Como clonar / modificar um repositório Git remoto (GitHub)

Conforme já visto anteriormente, em 7.1 Como iniciar um repositório Git local e em 7.2
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Conhecendo o Git no Apache NetBeans 16, com o Apache NetBeans 16 é possível desde

a inicialização / criação até a gestão completa de repositórios Git locais.

Com Apache  NetBeans 16  é  possível  também,  desde que configurado corretamente,

enviar  o  repositório  Git  local  para  um repositório  Git  remoto  armazenado  no  GitHub.

Entretanto, para trabalhar com repositórios Git remotos (GitHub) é recomendado que o

repositório Git  seja primeiramente criado no GitHub e em seguida clonado pelo

Apache  NetBeans  16 para  que  seja  desenvolvido  todo  trabalho  (modificações  /

inclusões)  no  repositório  Git  localmente  e,  por  fim,  sejam enviadas  as  alterações  ao

repositório Git remoto que está armazenado no GitHub.

7.3.1 Clonando um repositório Git remoto (GitHub)

Para clonar um repositório Git remoto diretamente do GitHub, siga os passos abaixo:

Observação:

 O repositório Git remoto a ser clonado a seguir, foi criado apenas para servir de

exemplo, e está disponível em https://github.com/idanielnorberto/aprenda-apache-

netbeans-16-para-php-8.1 (acessado em 23 dez 2022).

 Para clonar seu repositório Git remoto, será necessário conectar sua conta Github

no Apache NetBeans 16 utilizando um token de acesso, e para gerar esse token de

acesso proceda da seguinte maneira:

○ Acesse  https://github.com/settings/tokens,  faça  login (após login,  o  conteúdo da

página acessada deverá ser similar a imagem abaixo), e então clique em Personal

access tokens > Tokens (classic) > Generate new token >  Generate new token

(classic)
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○ Defina um “nome” para seu token (campo Note), um tempo de expiração (campo

Expiration) e selecione os escopos (campo  Select scopes) que seu  token terá

acesso. Se preferir preencha conforme a imagem abaixo, repare que o token a ser

gerado terá validade de 30 dias (após esse período será necessário gerar novo

token) e  possui  apenas o escopo  repo  selecionado (repo será  suficiente  para

gerenciar os repositórios pelo Apache NetBeans 16).

○ Role a página até o fim e clique em Generate token

○ Conforme a imagem abaixo, seu token gerado ficará visível e copiável apenas uma

vez, faça uma cópia e o salve em algum lugar seguro, pois será necessário para

prosseguirmos com os próximos passos deste eBook.
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○ Por  fim,  conforme  a  imagem  abaixo,  ao  acessar  /  atualizar  novamente

https://github.com/settings/tokens, seu  token aparecerá  desta  maneira,  ao  clicar

sobre ele, você poderá regenerá-lo (gera novo token de acesso, com as mesmas

configurações), deletá-lo, atualizar seu “nome” e escopos.

 Caso  ainda  tenha  dúvidas  para  gerar  token  de  acesso,  acesse

https://docs.github.com/pt/authentication/keeping-your-account-and-data-secure/

creating-a-personal-access-token (acessado em 23 dez 2022).

1º) Clique no menu Team, passe o ponteiro do mouse sobre Git e clique em Clone. 
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Team > Git > Clone…
Observação:

 Para  não  haver  conflito,  nenhum  projeto  deve  estar  selecionado  na  janela  de

projetos (3.3 Projects window) para executar o 1º passo.

2º) Preencher a primeira etapa (veja detalhes na imagem abaixo) do assistente  Clone

Repository. Após o preenchimento, clique em Next > para continuar. 

 Repository  URL: URL  do  repositório,  é  o  caminho  completo  de  onde  está

localizado o repositório remoto. 

 User: Insira seu usuário de acesso ao GitHub. 

 Password: Insira o token de acesso que foi gerado. 

 Clone into: Define (localmente) o caminho / diretório (pai) de destino onde será

criado o clone do repositório Git remoto informado em Repository URL. 

Observações:

 Para apenas clonar um repositório Git remoto (público) não é necessário informar

usuário (campo User) e token (campo Password) de acesso ao GitHub.

 Caso utilize sistema operacional Linux (Debian, Ubuntu e derivados), o caminho

definido em Clone into deverá se parecer com: /opt/lampp/htdocs.

 Caso utilize sistema operacional Windows 10 / 11, o caminho definido em Clone

into deverá se parecer como na imagem acima: C:\xampp\htdocs.
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3º) Preencher a segunda etapa (veja detalhes na imagem abaixo) do assistente  Clone

Repository. Após selecionar as  branches  nesta etapa, clique em Next >  para continuar.

Veja detalhes na imagem abaixo:

 Select  Remote  Branches:  Exibe  todas  as branches  remotas  disponíveis  para

serem  selecionadas  e  incluídas  no  processo  de  clonagem  do  repositório  Git

remoto. 

4º) Preencher a terceira etapa (veja detalhes na imagem abaixo) do assistente  Clone

Repository. Após o preenchimento, clique em Finish para finalizar o assistente.

 Parent Directory: Define (localmente) o diretório pai do diretório onde o repositório
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Git remoto será clonado.

 Clone Name: Nome do diretório onde o repositório Git remoto será clonado.

 Checkout Branch: Inicia projeto / estrutura de arquivos do repositório Git remoto

de acordo com a branch selecionada.

 Remote Name: Define o nome padrão para referenciar o repositório Git remoto.

 Scan for NetBeans Project after Clone: Deixe marcado essa opção, pois faz com

que o Apache NetBeans 16 escaneie repositório  que foi  clonado a procura de

projetos NetBeans.

Observações:

 Caso utilize sistema operacional Linux (Debian, Ubuntu e derivados), o caminho

definido em Parent Directory deverá se parecer com: /opt/lampp/htdocs.

 Caso utilize sistema operacional Windows 10 / 11, o caminho definido em Parent

Directory deverá se parecer como na imagem acima: C:\xampp\htdocs.

5º) Após finalizar com sucesso a clonagem do repositório, o Apache NetBeans 16 pode

não identificar os arquivos do repositório como um projeto NetBeans, então aparecerá a

seguinte janela (conforme a imagem abaixo) solicitando a criação de um projeto para que

seja possível trabalhar com esse repositório clonado no Apache NetBeans 16. Clique em

Create Project para continuar.

Solicitação da criação de um projeto NetBeans para o repositório clonado

Observação:

 Caso  você clone  algum outro  repositório  do  GitHub  e  o  Apache  NetBeans  16

identifique os arquivos desse repositório como um projeto NetBeans, basta clicar

em Open Project na janela que abrirá para que o projeto seja aberto na janela de

projeto (3.3 Projects window). Será preciso configurar a execução / implantação do

projeto. Com o projeto selecionado: File > Project Properties > Run Configuration.
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6º) Siga a etapas do assistente de criação do projeto, conforme abaixo:

1. Esta etapa, conforme imagem abaixo, serve para escolher o modelo de projeto.

Clique em PHP (à esquerda) e em seguida clique em PHP Application with Existing

Sources (à direita). Após a escolha clique em Next para continuar. 

2. Esta etapa conforme imagem abaixo, serve para definir a pasta de arquivos do

projeto (Sources Folder), o nome do projeto (Project Name), versão do PHP para

dicas (PHP Version), codificação padrão (Default Encoding) e opção para salvar

os metadados em um diretório separado. 

Para prosseguir, em Sources Folder defina o caminho completo até o diretório

onde se encontra o repositório Git remoto clonado, você pode digitar manualmente

ou se preferir  clique em  Browser... navegue até  o  diretório  e  selecione-o.  Em

Projects Name defina o nome projeto. Clique em Next para continuar. 
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Observações:

 Caso  utilize  sistema  operacional  Linux  (Debian,  Ubuntu  e  derivados),  o

caminho  definido  em  Sources  Folder  deverá  se  parecer  com:  

/opt/lampp/htdocs/aprenda-apache-netbeans-16-para-php-8.1.

 Caso utilize sistema operacional Windows 10 / 11, o caminho definido em

Sources  Folder  deverá  se  parecer  como  na  imagem  acima:  

C:\xampp\htdocs\aprenda-apache-netbeans-16-para-php-8.1.

3. Esta etapa serve para configurar o deploy (implantação) do projeto, que poderá ser

em servidor  local  ou em um servidor  remoto.  Utilizaremos nosso servidor  local

(XAMPP) e mais adiante veremos como fazer deploy em um servidor remoto. 

Em Run As, escolha a opção Local Web Server, em Project URL defina a URL

do  projeto  que  deverá  conter  http://localhost/aprenda-apache-netbeans-16-para-

php-8.1 (nome exato da pasta onde estão os arquivos do projeto) e em Index File

deverá apontar paro o arquivo index (quando houver).

Clique em Finish para finalizar.

109

https://github.com/idanielnorberto


Aprenda Apache NetBeans 16 para PHP 8.1 [eBook]. Feito por Daniel Norberto

Observações:

 As configurações pode ser alteradas. Selecione o projeto e depois:  File >

Project Properties > Run Configuration.

7º) Confira na janela de projeto (3.3 Projects window), conforme imagem abaixo, o projeto

referente ao repositório Git remoto clonado.

7.3.2 Trabalhando com um repositório Git remoto (GitHub)

Após a clonagem do repositório Git remoto vamos trabalhar de fato com ele a partir do

Apache NetBeans 16, o que envolve basicamente utilizar a opções Fetch (pegar), Pull

(puxar) e Push (empurrar), já visto (teoricamente) em 7.2.13 Remote.

7.3.2.1 Fetch

Para utilizar o Fetch, siga os passos abaixo:

1º) Com o projeto selecionado na janela de projetos (3.3 Projects window),  clique no

menu Team, pare o mouse sobre Remote e clique em Fetch. 

110

https://github.com/idanielnorberto


Aprenda Apache NetBeans 16 para PHP 8.1 [eBook]. Feito por Daniel Norberto

2º) Na primeira etapa do assistente, conforme imagem abaixo, escolha uma dentre as

seguintes opções e clique em Next.

 Select  Configured  Git  Repository  Location:  Mantém  as  configurações  do

repositório Git remoto, já definidas anteriormente.

 Specify  Git  Repository  Location:  Define  manualmente  as  configurações  do

repositório Git remoto que ainda não foi “acessado” via Apache NetBeans 16.

3º) Na segunda etapa do assistente, conforme imagem abaixo, selecione as  branches

remotas para pegar as modificações / atualizações e clique em Finish. 

Observações:

 As modificações / atualizações das branches remotas serão copiadas e podem ser

mescladas com a branch local, com o comando merge, já visto em 7.2.12 Branch /

Tag. 
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 Para visualizar as branches remotas copiadas, acesse Repository Browser, já visto

em 7.2.15 Repository. 

7.3.2.2 Pull

Para utilizar o Pull, siga os passos abaixo:

1º) Com o projeto selecionado na janela de projetos (3.3 Projects window),  clique no

menu Team, pare o mouse sobre Remote e clique em Pull. 

2º) Na primeira etapa do assistente, conforme imagem abaixo, escolha uma dentre as

seguintes opções e clique em Next.

 Select  Configured  Git  Repository  Location:  Mantém  as  configurações  do

repositório Git remoto, já definidas anteriormente.

 Specify  Git  Repository  Location:  Define  manualmente  as  configurações  do

repositório Git remoto que ainda não foi “acessado” via Apache NetBeans 16.

3º)  Na segunda etapa do assistente, conforme imagem abaixo, selecione as branches

remotas que deseja puxar as modificações / atualizações e clique em Finish. 
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Observação:

 As modificações / atualizações das branches remotas serão copiadas e mescladas

com a branch main local.

7.3.2.3 Push

Para utilizar o Push, siga os passos abaixo:

1º) Com o projeto selecionado na janela de projetos (3.3 Projects window),  clique no

menu Team, pare o mouse sobre Remote e clique em Push. 

2º) Na primeira etapa do assistente, conforme imagem abaixo, escolha uma dentre as

seguintes opções e clique em Next.
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 Select  Configured  Git  Repository  Location:  Mantém  as  configurações  do

repositório Git remoto, já definidas anteriormente.

 Specify  Git  Repository  Location:  Define  manualmente  as  configurações  do

repositório Git remoto que ainda não foi “acessado” via Apache NetBeans 16.

3º)  Na segunda etapa do assistente, conforme imagem abaixo, selecione as branches

locais com as modificações / atualizações que deseja empurrar / enviar e clique em Next.

4º)  Na terceira  etapa do assistente,  conforme imagem abaixo,  selecione as  branches

remotas que deseja serem atualizadas e clique em Finish.

Observação:

 O repositório Git remoto será atualizado de acordo com a versão mais recente do

seu repositório Git local.
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Capítulo 8 – Xdebug no Apache NetBeans 16

O Xdebug é uma extensão do PHP que auxilia na depuração e desenvolvimento de uma

aplicação PHP. O Xdebug nos oferece recursos como depuração em etapas, otimização

da função var_dump() (conforme imagem abaixo) e entre outros.

Resultado da função var_dump() em um array sem o Xdebug instalado.

Resultado da função var_dump() em um array com o Xdebug instalado.

Observações:

 No  Apache  NetBeans  16,  ao  executar  a  depuração  no  projeto  selecionado,  a

depuração por etapas é controlada pelas opções  Step do menu Debug, visto em

3.1.9 Debug.

 Para  saber  tudo  sobre  o  Xdebug,  acesse  a  documentação  oficial  (em  inglês)

https://xdebug.org/docs/. (Acessado em 23 dez 2022)

8.1 Instalando o Xdebug

Para instalar corretamente o Xdebug no sistema operacional Windows 10 / 11 ou Linux, é

preciso  que  já  tenha  instalado  os  softwares  necessários,  conforme  apresentado  no

Capítulo 2 – Softwares Necessários.

8.1.1 Instalação em Windows 10 / 11

Para instalar o Xdebug no Windows 10 /  11 e configurá-lo para funcionar no Apache
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NetBeans 16, siga os passos abaixo:

1º) Inicie o servidor Apache, conforme já visto em 2.1.1 Instalação em Windows 10 / 11

(7º passo). Mantenha o painel de controle do XAMPP aberto.

2º)  Digite  https://xdebug.org/files/php_xdebug-3.2.0-8.1-vs16-x86_64.dll no  navegador

para fazer o download do arquivo php_xdebug-3.2.0-8.1-vs16-x86_64.dll.

3º)  Após  o  download,  mova  o  arquivo  php_xdebug-3.2.0-8.1-vs16-x86_64.dll  para  o

diretório C:\xampp\php\ext (conforme imagem abaixo).

4º)  Ainda dentro do diretório  C:\xampp\php\ext  (conforme imagem abaixo),  renomeie o

arquivo  php_xdebug-3.2.0-8.1-vs16-x86_64.dll  para  php_xdebug.dll,  caso  já  tenha

algum arquivo com esse nome, substitua-o.

5º) No painel de controle do XAMPP (conforme a imagem abaixo), clique em Config. do

módulo Apache) e depois  PHP (php.ini).  O arquivo de configuração do PHP (php.ini)

será aberto.
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6º) Digite / insira as configurações abaixo no fim do arquivo php.ini. 

[ ]

;;;;;;;;;;;;;;;;;

; xdebug 3 ;

;;;;;;;;;;;;;;;;;

zend_extension = xdebug

xdebug.mode=debug,develop

xdebug.client_host=localhost

xdebug.client_port=9003

xdebug.idekey="netbeans-xdebug"

Com as configurações inseridas, o arquivo php.ini deverá se parecer conforme a imagem

abaixo.

7º) Salve as modificações no php.ini e reinicie o servidor Apache (basta clicar em stop e
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logo em seguida em start no módulo Apache do painel de controle o XAMPP).

8º) Para  conferir  se  o  Xdebug  foi  instalado,  abra  o  Navegador,  digite

http://localhost/dashboard/phpinfo.php     (página  de  informações  completas  do  PHP),

busque na página por “xdebug” e então exibirá as todas as informações relacionadas ao

Xdebug instalado (conforme as configurações inseridas no arquivo  php.ini  nos passos

anteriores). Veja algumas dessas informações nas imagens abaixo:

Observação:

 Caso não consiga acessar as informações por meio da URL acima, basta criar um

arquivo chamado  phpinfo.php  dentro de algum projeto,  inserir  o código  <?php

phpinfo(); ?> e executá-lo por meio de algum Navegador.
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8.1.2 Instalação em Linux (Debian, Ubuntu e derivados)

Para instalar o Xdebug no Linux e configurá-lo para funcionar no Apache NetBeans 16,

siga os passos abaixo:

1º)  Inicie o servidor Apache, conforme já visto em  2.1.2 Instalação em Linux (Debian,

Ubuntu e derivados) - 7º passo. Mantenha o painel de controle do XAMPP aberto.

2º)  Abra  o  Navegador  e  digite  https://xdebug.org/files/xdebug-3.2.0.tgz para  fazer  o

download do arquivo compactado xdebug-3.2.0.tgz.

3º) Após o download, abra o terminal de comandos Linux e digite cada comando (a partir

do $) a seguir separadamente e tecle “Enter” para executá-lo:

1. sudo apt install php-dev autoconf automake - Este comando instala php-dev,

instala o  autoconf, instala o  automake  e os todos pacotes necessários para que

funcionem corretamente. É necessário informar a senha. Aguarde a conclusão da

instalação.

2. cd Downloads/ - Este comando acessa o diretório Downloads a partir do diretório

do usuário do sistema, nesse caso, diretório daniel. 

3. ls -  Este comando lista todos os arquivos e diretórios que o diretório Downloads

possui, nesse caso listou xdebug-3.2.0.tgz.

4. tar  -xvzf  xdebug-3.1.5.tgz -  Este  comando  descompacta  o  arquivo  xdebug-

3.2.0.tgz, para um diretório chamado xdebug-3.2.0. Aguarde a extração completa.

5. cd xdebug-3.2.0/ - Este comando acessa o diretório xdebug-3.2.0 que está dentro

do diretório Downloads.
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6. sudo /opt/lampp/bin/phpize - Este comando prepara o ambiente para a criação

de uma extensão PHP. Se necessário informe a senha. O resultado deverá ser

parecido conforme a imagem acima (A partir de Configuring for…).

7. sudo ./configure --with-php-config=/opt/lampp/bin/php-config - Este comando

executa  configure  (checa configurações e gera arquivo para ser  compilado) de

acordo  com a  versão  do  PHP instalado  via  XAMPP.  Se  necessário  informe a

senha. Aguarde a execução.

8.  sudo make -  Este comando compilará o arquivo gerado a partir  do  configure

(passo anterior). Se necessário informe a senha. Aguarde a compilação. Ao final

será gerado o arquivo xdebug.so. 

Observação: 

 Caminho completo do arquivo xdebug.so:

 /home/daniel/Downloads/xdebug-3.2.0/modules/xdebug.so

9. sudo cp modules/xdebug.so /opt/lampp/lib/php/extensions/no-debug-non-zts-

20210902/ -  Este comando copia o arquivo xdebug.so para o diretório  no-debug-

non-zts-20210902. Se necessário informe a senha.

10. sudo chmod 777 /opt/lampp/etc/php.ini - Este comando dá permissão completa de

leitura e escrita para o arquivo  php.ini (arquivo de configurações do PHP).  Se

necessário informe a senha.

11. Conforme a imagem acima, vá para o diretório etc (/opt/lampp/etc) e clique sobre

o arquivo php.ini para abri-lo. 
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12. Digite / insira as configurações abaixo no arquivo php.ini. 

[ ]

;;;;;;;;;;;;;;;;;

; xdebug 3 ;

;;;;;;;;;;;;;;;;;

zend_extension = xdebug

xdebug.mode=debug,develop

xdebug.client_host=localhost

xdebug.client_port=9003

xdebug.idekey="netbeans-xdebug"

Com as configurações inseridas, o arquivo php.ini deverá se parecer conforme a

imagem abaixo.

13. Salve as modificações no arquivo  php.ini e  reinicie  o  servidor  Apache (com o

Apache Web Server selecionado no painel de controle do XAMPP, basta clicar em

stop e logo em seguida em start).

14. Para  conferir  se  o  Xdebug  foi  instalado,  abra  o  Navegador,  digite

http://localhost/dashboard/phpinfo.php     (página de informações completas do PHP),

busque  na  página  por  “xdebug”  e  então  exibirá  as  todas  as  informações

relacionadas ao Xdebug instalado (conforme as configurações inseridas no arquivo

php.ini  nos passos anteriores).  Veja algumas dessas informações nas imagens

abaixo:
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Observação:

 Caso não consiga acessar as informações por meio da  URL acima, basta

criar um arquivo chamado  phpinfo.php dentro de algum projeto, inserir o

código <?php phpinfo(); ?> e executá-lo por meio de algum Navegador.

8.2 Iniciando uma sessão de depuração de uma aplicação PHP

Para iniciar a sessão de depuração de uma aplicação PHP (será utilizado abaixo um

projeto simples apenas para exemplificar), siga o seguinte passos:

1º) Selecione, na janela de projetos (3.3 Projects window), o projeto a ser depurado.
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2º) Clique no menu Debug e em seguida Debug Project (hello-xdebug).

3º)  Será iniciada uma sessão para a depuração da aplicação PHP. Será aberta uma

página no navegador (conforme a primeira imagem abaixo) para a sessão e no Apache

NetBeans  16  (conforme  a  segunda  imagem  abaixo)  será  aberto  o  arquivo  principal

index.php  com a primeira linha do  script selecionada (cor  verde)  para ser  depurada,

atalhos do menu Debug (visto em 3.1.9 Debug) na barra de ferramentas, algumas janelas

específicas de depuração (visto em 3.1.11 Window) e informação que a sessão está em

execução.
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4º) Clique em Step Into na barra de ferramentas para ir passo a passo no processo de

depuração da aplicação PHP ou clique alguma opção de acordo a sua necessidade (a

definição  de  cada opção no processo  de depuração já  foi  vista  em  3.1.9  Debug).  O

depurador  analisará o nosso código e exibir  os resultados nas janelas específicas de

depuração, por exemplo, se possuir algum breakpoint definido pelo Apache NetBeans 16

no  nosso  código, será  exibido  informações  sobre  esse  breakpoint  em  uma  janela

específica.

Seguindo com nosso exemplo (contém apenas algumas variáveis), ao ir clicando em Step

Into, o depurador foi analisando uma linha de cada vez (a cada passo) e identificando as

variáveis  e  seus  respectivos  valores,  exibindo  o  resultado  na  janela  específica  de

variáveis (conforme imagem abaixo).

124

https://github.com/idanielnorberto


Aprenda Apache NetBeans 16 para PHP 8.1 [eBook]. Feito por Daniel Norberto

Observações:

 Os valores exibidos na coluna Value já eram esperados para as variáveis $x e $h,

pois seus valores foram atribuídos diretamente a elas no arquivo index.php. 

 Na variável  $hx não há um valor “esperado” explicitamente, então o depurador

analisa  o  código  e  exibe  o  valor  que  a  variável $hx  possui  no  momento  da

depuração, neste caso foi “Hello Xdebug”.

 Provavelmente em algum momento, algum projeto receberá valores via formulário,

então para prosseguir com a depuração da aplicação, será necessário preencher

as  informações  do  formulário  no  navegador  que  está  com  a  sessão  Xdebug

iniciada e depois voltar novamente para o Apache NetBeans 16 para continuar com

o processo de depuração.

5º) Após a execução da última linha, se não houver mais nenhuma “passo”, a saída para

o navegador é permitida (conforme imagem abaixo).
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Observação:

 Se houver um recarregamento da página ou envio de algum formulário, o processo

de depuração se inicia novamente no Apache NetBeans 16. Isso acontece porque

a sessão de depuração ainda não foi encerrada.

6º) Para encerrar a sessão de depuração (veja a imagem abaixo), clique no ícone de

Finish Debugger Session na barra de ferramentas ou clique no pequeno X que está ao

lado da barra de execução da depuração na parte inferior interface do Apache NetBeans

16 e em seguida clique em Yes. 
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Após a finalização da sessão de depuração no Apache NetBeans 16, será exibida no

navegador a confirmação do encerramento da sessão (conforme a imagem abaixo).
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Capítulo 9 – Deploy do projeto em um servidor remoto
(via FTP)

Neste capítulo veremos primeiramente como configurar o Apache NetBeans 16 para cria

uma conexão com um servidor remoto via FTP (File  Transfer Protocol  /  Protocolo de

transferência  de  arquivos)  e  depois  como  utilizá-lo  para  enviar  (Upload)  e  receber

(Download)  arquivos  diretamente  de  um  servidor  remoto,  que  no  caso  será  uma

hospedagem.

9.1 Configurando o Apache NetBeans 16 para utilizar o FTP

Para configurar o Apache NetBeans 16 para utilizar o FTP siga os passos abaixo:

Observação:

 Será utilizado como exemplo o  projeto  helloworld  que criado no  Capítulo  5 –

Criação e deploy de um projeto em um servidor local.

 Caso queira efetuar a configuração, é necessário que tenha os dados enviados

pela  sua  hospedagem  para  configurar  o  FTP  no  Apache  NetBeans  16

corretamente.

1º) Selecione o projeto helloworld na janela de projetos (3.3 Projects window), conforme

a imagem abaixo.

2º) Clique  no  menu  File e  depois  em  Project  Properties  (helloworld).  Ver  imagem

abaixo.
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3º) Conforme a imagem abaixo, na janela de propriedades do projeto (Project Properties):

● Clique na categoria Run Configuration (primeira seta vermelha).

● Em Run As (segunda seta vermelha), selecione Remote Web Site (FTP, SFTP).

● Em  Remote  Connection (terceira  seta  vermelha),  clique  em Manage… para

criarmos uma conexão remota.
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Observação:

 Em Project URL, é mantido a URL local do nosso projeto, pois assim será possível

trabalhá-lo e testá-lo localmente por meio desta URL e então quando for feito o

envio (upload) do projeto para o servidor remoto basta acessar a URL do site,

como, por exemplo, seudominio.com / seudominio.com.br ou entre outros.

4º) Conforme a imagem abaixo, defina o nome da conexão (Connection Name), tipo de

conexão (Connection Type) e clique em OK.

5º) Conforme a  imagem abaixo,  vamos configurar  e  testar  a  conexão que  foi  criada

helloworld_ftp.
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 Host name: Insira nome do Host FTP ou nome do Host secundário fornecido pela

hospedagem. 

 User Name: Insira nome de usuário FTP fornecido pela hospedagem.

 Password: Insira senha de usuário FTP fornecida pela hospedagem.

 Initial  Directory:  Insira diretório inicial  definido pela hospedagem (este diretório

será o ponto de partida do seu site, e pode variar dependendo da hospedagem).

Você  pode  encontrá-lo  diretamente  no  gerenciador  de  arquivos  de  sua

hospedagem. 

Após preencher os campos, clique em Test Connection para testar a conexão, se estiver

correto as informações passadas na configuração, aparecerá a mensagem  Connection

succeeded (clique em OK para fechar), e, por fim, clique OK novamente para finalizar. 

Observações: 

 O Host Name informado como exemplo na imagem acima é de um site que está

hospedado na Hostoo (https://hostoo.io).

 A  Hostoo é  uma  hospedagem  cloud  para  sites  e  aplicações  web  PHP,  sem

compartilhamento  de  recursos,  com  a  melhor  performance  do  mercado,  com

contas de e-mail ilimitadas e muitos outros recursos.

 Faça seu cadastro e teste gratuitamente, clicando aqui.
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6º) Conforme a imagem abaixo, na janela de propriedades do projeto (Project Properties)

novamente, em  Remote Connection escolha a conexão FTP que foi criada no passo

anterior e em Upload Files escolha a opção Manually para que os seus arquivos sejam

enviados manualmente para o servidor remoto. Por fim, clique em OK para concluir.

9.2 Utilizando o Apache NetBeans 16 para fazer upload e download
de arquivos em um servidor remoto (via FTP)

A seguir veremos como utilizar o Apache NetBeans 16 para fazer upload e download (via

FTP) de arquivos em um servidor remoto.

9.2.1 Download de arquivos de um servidor remoto

Para fazer o download de arquivos de um servidor remoto, siga os passos abaixo:

1º) Conforme a imagem abaixo, na janela de projetos (3.3 Projects window) clique com o botão

direito do mouse sobre Source Files e em clique em Download...
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2º)  Conforme a imagem abaixo, na janela File Download, escolha os arquivos que quer

fazer o download e clique em Download.

Observação: 

 Se existir arquivos com o mesmo nome, serão sobrescritos.

Caso apareça a janela Remote Synchronization (conforme a imagem abaixo), marque a

caixinha e clique em No. 
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O  processo  de  execução  do  download  será  exibido  na  janela  de  saída  (3.8  Output

window), conforme a imagem abaixo.

3º) Após o download, conforme a imagem abaixo, o(s) arquivo(s) estará(ão) disponível(is)

no projeto, dentro de Source Files.

9.2.2 Upload de arquivos para um servidor remoto

Para fazer o upload de arquivos para um servidor remoto, siga os passos abaixo:

1º) Conforme a imagem abaixo, na janela de projetos (3.3 Projects window) clique com o botão

direito do mouse sobre Source Files e em clique em Upload...

2º) Conforme a imagem abaixo, na janela File Upload, escolha os arquivos que quer fazer

o upload e clique em Upload.

Observação: 
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 Se existir arquivos com o mesmo nome, serão sobrescritos.

Caso apareça a janela Remote Synchronization (conforme a imagem abaixo), marque a

caixinha e clique em No. 

O processo de execução do upload será exibido na janela de saída (3.8 Output window),

conforme a imagem abaixo.

135

https://github.com/idanielnorberto


Aprenda Apache NetBeans 16 para PHP 8.1 [eBook]. Feito por Daniel Norberto

3º) Após o upload, conforme a imagem abaixo, você pode acessar o seu site e conferir se

está tudo está funcionando corretamente. 

E também, você pode acessar a sua hospedagem e verificar dentro diretório definido

como inicial na configuração do FTP (5º passo em 9.1 Configurando o Apache NetBeans

16 para utilizar o FTP) se o(s) arquivo(s) está(ão) disponível(is). Veja imagem abaixo.

Gerenciador de arquivos no painel da Hostoo
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Considerações finais do autor

Parabéns por ter chegado até aqui! Coloque em prática tudo que aprendeu, utilize este

eBook como um guia sempre que precisar e explore ainda mais o Apache NetBeans 16 e

suas  versões  futuras,  para  que  possa  aprender  cada  vez  mais  sobre  este  poderoso

software.

Espero  ter  contribuído  de  verdade  para  o  seu  conhecimento  e  ambiente  de

desenvolvimento após a leitura deste eBook. 

Um grande abraço! 

Dúvidas, Sugestões, Elogios, Erros

 Email: aprendanetbeans@gmail.com 

 Site: aprendanetbeans.github.io
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